Web lists-archives.com

Re: [Samba] Updating Samba




Try it like this. 

Steps for samba 4.8.x on Ubuntu 14.04 

# install basic build tools
apt-get install dpkg-dev build-essential make automake

# use the build depends from ubuntu's package as base. 
apt-get build-dep samba

# Install the extra packages you need for building samba on ubuntu 14.04. 
apt-get install pkg-config xsltproc python-dev gnutls28-dev libacl1-dev libpam0g-dev
/.configure

'configure' finished successfully (1m10.512s)

And now build samba. ;-) 

Please note, the get you to build samba, i've not tested these myself. 
I do really advice you go upgrade to ubuntu 18.04 and then install/upgrade samba. 
And the exra bonus then is, you can use my Debian stretch packages on ubuntu 18.04. 

And other way is, use the ubuntu 18.04 source, get that version and use that. 
The side note here is, you need to change the debian/control file so the needed sources and versions of these match. 


Greetz, 

Louis


> -----Oorspronkelijk bericht-----
> Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens 
> Andrew Bartlett via samba
> Verzonden: maandag 13 augustus 2018 3:27
> Aan: Rowland Penny; samba@xxxxxxxxxxxxxxx
> Onderwerp: Re: [Samba] Updating Samba
> 
> On Sun, 2018-08-12 at 13:01 +0100, Rowland Penny via samba wrote:
> > On Sun, 12 Aug 2018 13:34:50 +0200
> > René Schmidt via samba <samba@xxxxxxxxxxxxxxx> wrote:
> > 
> > > Hello everybody,
> > > 
> > > I have an Ubuntu server installed on the Samba 4.3.11 
> Ubuntu from the
> > > Ubuntu sources. Now I want to update Samba. I downloaded 
> the version
> > > 4.8.3 of samba.org (tar.gz) and unzipped it. ./configure 
> always fails:
> > > 
> > > Checking for program krb5-config.heimdal: not found
> > > Checking for program krb5-config: not found
> > > Checking for program pkg-config: not found
> > > Checking for gnutls> = 3.4.7: not found
> > > Checking for program pkg-config: not found
> > > Checking for gnutls> = 3.0.0s: not found
> > > Checking for program pkg-config: not found
> > > Checking for gnutls> = 1.4.0 and broken versions: not found
> > > /srv/wget/samba-4.8.3/source4/lib/tls/wscript:51: error: 
> Building the
> > > AD DC requires GnuTLS (eg libgnutls-dev, gnutls-devel) 
> for ldaps: //
> > > support and for the BackupKey protocol
> > > 
> > > But libgnutls-dev is installed:
> > > dpkg -l | grep libgnutls-dev
> > > ii libgnutls-dev 2.12.23-12ubuntu2.8 amd64 GNU TLS library -
> > > development files
> > > 
> > > Where is the problem?
> > > 
> > > Many thanks for the help...
> > > 
> > > 
> > > 
> > 
> > You do not seem to have all the required build packages installed.
> > You also haven't told us what version of Ubuntu you are using.
> 
> This is quite likely the issue, the gnutls checks rely on pkg-config.
> 
> Andrew Bartlett
> 
> -- 
> Andrew Bartlett
> https://samba.org/~abartlet/
> Authentication Developer, Samba Team         https://samba.org
> Samba Development and Support, Catalyst IT   
> https://catalyst.net.nz/services/samba
> 
> 
> 
> 
> 
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba
> 
> 


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba