Web lists-archives.com

Re: [Samba] Member server winbind issue




On Tue, 26 Jun 2018 12:33:04 +0200
Franz Gansberger via samba <samba@xxxxxxxxxxxxxxx> wrote:

> Hi All,
> 
> sorry for reopening this thread.
> Since I'm still at the same point - with special circumstances - could
> this be Debian-Release-related?
> 
> In detail: 
> On Debian 8.11, Samba Version 4.5.16 from Louis' repository,  wbinfo
> -g, wbinfo -u and getent group AD\\groupname ist working - getent
> passwd AD\\username returns noting but 

wbinfo -u & -g just shows that the users and groups exist in AD.
getent will only show windows users & groups if everything is set up
correctly. 

> 
> [2018/06/26 12:26:12.721628,  5]
> ../source3/winbindd/winbindd_getpwnam.c:137(winbindd_getpwnam_recv)
>   Could not convert sid S-0-0: NT_STATUS_INVALID_PARAMETER
>

I wouldn't worry about the above.
 
> If I just update the same machine to Debian 9.4, using the same
> smb.conf, same samba version from Louis' repository, all is working. 

Now this doesn't really make sense, unless it is pulling in some
package(s) that weren't installed before.

> 
> Had this as only solution on two different machines.

How 'idmap config' is setup changed at 4.6.0, but you seem to be
saying you are still using 4.5.16 on Debian 9, so this shouldn't come
into play.

You should be able to use 4.8.2 from Louis's repo on Debian 9, I would
usually advise using the latest stable version of Samba possible
(though there have been exceptions).

Can you please post your smb.conf again, I cannot remember what it
contains.

Rowland
 

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba