Web lists-archives.com

[Samba] samba problem with version upgrade - restated




I am taking the unusual measure of posting before anyone responds to my post as something occurred to me and the results of testing it yields useful information relevant to my problem.

It finally occurred to me that the behavior I am seeing with sylvia, specifically the fact that a file added via the share from the other system gets ownership of "nobody/nogroup", that perhaps 4.3.11 was treating this access as anonymous/guest instead of as intended. Looking at my share I see in both files I have "guest ok = yes" in the share definition, so this was a possibility.

I edited the share on both systems to change this to "guest ok = no" and tried again with both systems. This resulted completely different behavior on sylvia system, but no change with maya.

With the sylvia booted gigolo cannot get the share mounted, it continues to prompt for the password, apparently failing to validate it. There are no error messages given on the other system, just another prompt for the password.

Looking at /var/log/auth.log I see:

Jun 11 11:38:48 DG41TY smbd: pam_unix(samba:session): session closed for user nobody Jun 11 11:39:50 DG41TY smbd: message repeated 5 times: [ pam_unix(samba:session): session closed for user nobody]

This was after shutting sylvia down and booting maya.

So this does appear to be some sort of authentication issue with 4.3.11 here. Would additional logging help isolate the problem? If so, what particular settings should I add?

Dave

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba