Web lists-archives.com

Re: [Samba] Got "I have no name!" error after deleting a samba user whose username is identical to the AD user




On Thu, 24 May 2018 15:50:51 +0800
Yangyang Zhang <sinstar00@xxxxxxxxx> wrote:

> Hi,
> 
> Thanks for your quick response.
> 
> Now I come to a better understanding about Samba and how AD works.
> 
> I wonder is there any quick fix for the "I have no name!" problem.
> Because I cannot login Ubuntu via SSH.
> Now I have to use another user and use `su zhangyy` to use my user.
> 
> One more question, is there a proper way to let the AD user shares
> its home directory on Samba using the same password?
> 
> Thanks for your time and consideration.
> 

Your smb.conf is mostly correct and if there is a user in AD (and only
in AD) called 'zhangyy' you should be able to log in, provided that
libnss_winbind and PAM are set up correctly. If you cannot log in, then
I would stop smbd, nmbd and winbindd, go to /var/lib/samba and remove
all the .tdb & .ldb files under that directory, restart Samba and run
'getent passwd zhangyy', if this produces output, then you are good to
go. I would also remove any users or groups called 'zhangyy'
from /etc/passwd or /etc/group if they exist.

It might also be a good idea to read this:

https://wiki.samba.org/index.php/Main_Page

Especially this:

https://wiki.samba.org/index.php/Setting_up_Samba_as_a_Domain_Member

Rowland

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba