Web lists-archives.com

Re: [Samba] Erro Join new DC




On Sun, 20 May 2018 15:49:30 -0300
Carlos via samba <samba@xxxxxxxxxxxxxxx> wrote:

> HI!!
> 
> For information only:
> 
> In my tests:
> Samba 4 version 7.X or 8.x
> Dont join in same version or after, only necessary join with versio
> 6.X, and after upgrade..
> 
> Exemple:
> 
> Samba 4 7.7 DC:
> 
> New
> Join new DC with samba 4 6.X -> OK
> 
> New
> Join new DC with samba 4 7.X -> Erro
> 
> New
> Join new DC with samba 4 8.X -> Erro
> 
> 
> Samba 4 8.X DC:
> 
> New
> Join new DC with samba 4 6.X -> OK
> 
> 
> New
> Join new DC with samba 4 7.X -> Erro
> 
> New
> Join new DC with samba 4 8.X -> Erro
> 
> 
> Is correct ?
> 
> Regards;
> 

You should be able to join 4.7.x to a 4.6.x and visa versa and I am now
reliably informed that the same goes for 4.8.x
The only problem should be when upgrading to 4.8.0 or 4.8.1 on a DC

There doesn't seem to be the case though, there have been several
cases of problems upon joining a 4.8.X DC to a domain.
My thoughts are, (and I could be totally wrong here) the pre-4.8.x DB
gets replicated to the new 4.8.x DC and then gets updated to the new
system and promptly falls over, just like when you upgrade Samba.

What is the error you get when the join fails.

Rowland
 

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba