Web lists-archives.com

Re: [Samba] re: re: access domain via ldap failed




On Thu, 03 May 2018 10:38:03 +0800
"ryanyang51@xxxxxxx" <ryanyang51@xxxxxxx> wrote:

The relevant configure options start here:
 
> CONF_OPTS="\
> 
> --enable-cups \
> 
> --enable-gnutls \
> 
> --with-acl-support \
> 
> --with-automount \
> 
> --with-pam \
> 
> --without-profiling-data \
> 
> --with-quotas \
> 
> --with-syslog \
> 
> --with-utmp \
> 
> --with-winbind \
> 
> --with-ads \
> 
> --with-dnsupdate \
> 
> --with-cluster-support \
> 
> %if %{with_libarchive}
> 
> --with-libarchive \
> 
> %else
> 
> --without-libarchive \
> 
> %endif
> 
> %if %{make_dmapi}
> 
> --with-dmapi \
> 
> %else
> 
> --without-dmapi \
> 
> %endif
> 
> --with-shared-modules=%{shared_modules} \"


Which, in my opinion, could be just this:

CONF_OPTS="\

--with-cluster-support \

--with-shared-modules=%{shared_modules} \"

All the rest are just the default settings.

There doesn't seem to be any reason why ldap doesn't work, do you have
the packages for your distro installed, see here:

https://wiki.samba.org/index.php/Package_Dependencies_Required_to_Build_Samba

Failing that, is there a firewall in the way, or selinux ?

Rowland

> 
> ./configure $PATH_OPTS $BUILD_OPTS $CONF_OPTS
> 
> 
> 
> I use the dependent packages that suit for 4.5.x. It also support me
> to complete the compile process. So if it can cause the problem for
> the version reason?
> 

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba