Web lists-archives.com

Re: [Samba] 4.2.14 (or newer) support "Windows for Workgroups 3.1a"?




On Mon, Apr 30, 2018 at 10:42 AM Andrea Baldoni via samba <
samba@xxxxxxxxxxxxxxx> wrote:

> Hello.
>
> I need to let Windows for Workgroup 3.11 clients (industrial machinery)
> connect to shares in the PDC samba Version 4.2.14-Debian.
>

I have a couple win9x and DOS machine controllers in a similar situation.
I decided that having these on the domain was less important than running a
little bit tighter security for the rest of my LAN, so I have this work
around and it seems to be working well enough:

- I have a virtual machine running samba 4.x standalone with these global
options:
   lanman auth = Yes
   client lanman auth = Yes
   server signing = disabled
   create mask = 0664
   directory mask = 0775
- the last 2 are needed to play nice over NFS when using ACL group based
permissions on the source server.
- my main samba AD file server exports the folders I want these old system
to access via NFS to only this VM.
- the VM has only the required local users and groups created to match the
UIDs of the domain.

I guess a container would work too, just I have VM hosts with plenty of
resources so that was most flexible for me.

the drawback of this is the user management is outside the domain, but here
these are station specific shared accounts on auto-login anyway, so not
being on the domain is actually a bit beneficial.
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba