Web lists-archives.com

Re: [Samba] [BUG] Fail update Samba 4.8.0




On Thu, 26 Apr 2018 16:43:13 -0400
Rafael Oliveira d'Ávila <davilatr@xxxxxxxxx> wrote:

>  As guidance, we look forward to Samba 4.8.1 for upgrade.
> However, the same bug remains in version 4.8.0
> Again I will go back to the previous version (4.7.5)
> 
> Does anyone else share this problem?
> 
>  samba4.service - LSB: start and stop samba4
>    Loaded: loaded (/etc/rc.d/init.d/samba4; bad; vendor preset:
> disabled) Active: active (running) since Thu 2018-04-26 16:32:31 -04;
> 6 minutes ago Docs: man: systemd-sysv-generator (8)
>   Process: 10336 ExecStop = / etc / rc.d / init.d / samba4 stop (code
> = exited, status = 0 / SUCCESS)
>   Process: 31614 ExecStart = / etc / rc.d / init.d / samba4 start
> (code = exited, status = 0 / SUCCESS)
>    CGroup: /system.slice/samba4.service
>            ├─31621 / usr / local / samba / sbin // samba -D
>            ├─31628 / usr / local / samba / sbin // samba -D
>            ├─31629 / usr / local / samba / sbin // samba -D
>            ├─31631 / usr / local / samba / sbin // samba -D
>            ├─31633 / usr / local / samba / sbin // samba -D
>            ├─31634 / usr / local / samba / sbin // samba -D
>            ├─31635 / usr / local / samba / sbin // samba -D
>            ├─31636 / usr / local / samba / sbin // samba -D
>            ├─31637 / usr / local / samba / sbin // samba -D
>            ├─31638 / usr / local / samba / sbin // samba -D
>            ├─31639 / usr / local / samba / sbin // samba -D
>            ├─31641 / usr / local / samba / sbin // samba -D
>            └─31643 / usr / local / samba / sbin // samba -D
> samba [31643]: [2018/04/26 16: 32: 37.364664, 0]
> ../lib/util/util_runcmd.c:327(samba_runcmd_io_handler)
> samba [31643]: / usr / local / samba / sbin / samba_dnsupdate: vars
> ['HOSTNAME'] = samdb.host_dns_name ()
> samba [31643]: [2018/04/26 16: 32: 37.364743, 0]
> ../lib/util/util_runcmd.c:327(samba_runcmd_io_handler)
> samba [31643]: / usr / local / samba / sbin / samba_dnsupdate: File
> "/usr/local/samba/lib64/python2.7/site-packages/samba/samdb.py", line
> 653, in host_dns_name
> samba [31643]: [2018/04/26 16: 32: 37.365014, 0]
> ../lib/util/util_runcmd.c:327(samba_runcmd_io_handler)
> samba [31643]: / usr / local / samba / sbin / samba_dnsupdate: return
> res [0] ['dNSHostName'] [0]
> samba [31643]: [2018/04/26 16: 32: 37.365167, 0]
> ../lib/util/util_runcmd.c:327(samba_runcmd_io_handler)
> samba [31643]: / usr / local / samba / sbin / samba_dnsupdate:
> KeyError: 'No such element'
> samba [31643]: [2018/04/26 16: 32: 37.393083,
> 0] ../source4/dsdb/dns/dns_ update.c:330(dnsupdate_nameupdate_done)
> samba [31643]: ../source4/dsdb/dns/dns_update.c:330: Failed DNS
> update - with error code 1
> 
> 
> samba_dnsupdate
> 
> Unable to determine the DomainSID, can not enforce uniqueness
> constraint on local domainSIDs
> 
> Searching for dsServiceName in rootDSE failed: operations error at
> ../source4/dsdb/samdb/ldb_modules/rootdse.c:516
> Failed to find our own NTDS Settings DN in the ldb!
> Searching for dsServiceName in rootDSE failed: operations error at
> ../source4/dsdb/samdb/ldb_modules/rootdse.c:516
> Failed to find our own NTDS Settings DN in the ldb!
> Searching for dsServiceName in rootDSE failed: operations error at
> ../source4/dsdb/samdb/ldb_modules/rootdse.c:516
> Failed to find our own NTDS Settings DN in the ldb!
> Traceback (most recent call last):
>   File "/ usr / local / samba / sbin / samba_dnsupdate", line 748, in
> <module>
>     sub_vars = get_subst_vars (samdb)
>   File "/ usr / local / samba / sbin / samba_dnsupdate", line 370, in
> get_subst_vars
>     vars ['HOSTNAME'] = samdb.host_dns_name ()
>   File
> "/usr/local/samba/lib64/python2.7/site-packages/samba/samdb.py", line
> 653, in host_dns_name return res [0] ['dNSHostName'] [0]
> KeyError: 'No such element'
> 
> 
> *Atte.*
> 
> *Rafael d'Ávila.*
> 
> *"O único lugar onde o sucesso vem antes do trabalho é no
> dicionário."*
> 
> 2018-04-24 9:35 GMT-04:00 Rowland Penny via samba
> <samba@xxxxxxxxxxxxxxx>:
> 
> > On Tue, 24 Apr 2018 09:22:48 -0400
> > Rafael Oliveira d'Ávila via samba <samba@xxxxxxxxxxxxxxx> wrote:
> >
> > > After performing the update of samba version 4.7.3 to version
> > > 4.8.0, an error occurred while starting the service.
> > >
> > >
> > > Can someone help me? Did you solve this problem?
> > >
> > > I did the donwgrade for the service to work.
> > >
> >
> > That is how you solve this problem, DO NOT UPGRADE TO 4.8.0, it is
> > borked, faulty, got a bug, however you want to put it ;-)
> >
> > Just wait until 4.8.1 comes out, it will contain the fix for this
> > problem.
> >
> > Rowland

Unfortunately, whilst a fix for this is in master, for various reasons,
it didn't make it into 4.8.1. This means that 4.8.1, like 4.8.0, is
unusable for upgrade purposes.

Sorry

Rowland


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba