Web lists-archives.com

Re: [Samba] Samba 4 - ISO-8859-15 filenames not listed while browsing




Thanks for your reply.




> Can you add a step that runs iconv over the generated
> filenames that converts them to utf-8 ?
>


Indeed my choices are limited as I don't have the hand on the application,
and the devs won't hear anything, so adding a conversion step would not be
possible. I know the problem come from that, but my hands are tied.


The problem was always there, it's just that it was 'masked' before, and
the customer is used to filenames not displaying correctly, but obviously
missing files is more of a problem.


If not, setting unix charset = iso-8859-15 works, as
> you've found, but smbd must convert the characters.

I doubt that is making your access slow though, as
> filename conversion is pretty fast and not usually
> something affecting the fast-path.
>

Is there a way for me to pinpoint where the slowness issue can come from?
Or tune some parameters that might help in this matter?
I can clearly see the difference in performance between setting the 'unix
charset' to 'iso8859' and leaving it to its default 'utf8' value.


I was hoping to find a way for the samba4 server to behave like samba3 (as
in ignoring bad characters and replacing them with an underscore
character), which in the end resulted in the best compromise.

Any advices are welcomed.
Thank you for your time and help.

Regards.
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba