Web lists-archives.com

Re: [Samba] Update from el7.4 to el7.5 broke samba 4.6.14





Hi Rowland,
Yes, I noticed that el7.5 had samba 4.7.1. Unfortunately, one cannot use that version as an AD DC. Here's the situation:

# rpm -ql samba-dc
/usr/share/doc/samba-dc-4.7.1
/usr/share/doc/samba-dc-4.7.1/README.dc

(and it mentions that because of MIT kerberos the samba AD DC features cannot be enabled on el7 at this moment).

Perhaps the best way forward would be to rebuild samba-4.7.7 from src.rpm (from Wing's repo) and try to make use of the libs provided on el7.5.

Vincent

On Wed, 18 Apr 2018, Rowland Penny via samba wrote:

On Wed, 18 Apr 2018 14:26:07 +0200
"L.P.H. van Belle via samba" <samba@xxxxxxxxxxxxxxx> wrote:

Sorry for all these replies, i missed this.

Is the upgrade path from samba 4.6 + libldb 1.1 to samba 4.6 +
libldb 1.3
No, that wil break your samba!!!
Samba 4.6 max 1.1.29 for ldb.


I gave the guy a hint, if you go here:

http://wing-net.ddo.jp/wing/7/x86_64/

The very first rpm is:

ldb-tools-1.1.29-2.el7_4.wing.x86_64.rpm

I am fairly sure he needs to install this, but a better idea is to do
what Louis suggested, upgrade to 7.5 and use Samba from there.

Rowland

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba