Web lists-archives.com

Re: [Samba] Fwd: Re: Erro Upgrade Samba 4.6.3 to 4.8




On Mon, 19 Mar 2018 12:13:23 -0300
Carlos via samba <samba@xxxxxxxxxxxxxxx> wrote:

> Hi!
> 
> Thanks for answer.
> 
> Start-Date: 2018-03-19  12:00:50
> Commandline: apt-get install winbind
> Install: python-crypto:amd64 (2.6.1-4ubuntu0.2, automatic), 
> update-inetd:amd64 (4.43, automatic), python-samba:amd64 
> (4.3.11+dfsg-0ubuntu0.14.04.14, automatic), winbind:amd64 
> (4.3.11+dfsg-0ubuntu0.14.04.14), tdb-tools:amd64 
> (1.3.8-0ubuntu0.14.04.1, automatic), samba:amd64 
> (4.3.11+dfsg-0ubuntu0.14.04.14, automatic), python-tdb:amd64 
> (1.3.8-0ubuntu0.14.04.1, automatic), libtevent0:amd64 
> (0.9.28-0ubuntu0.14.04.1, automatic), samba-dsdb-modules:amd64 
> (4.3.11+dfsg-0ubuntu0.14.04.14, automatic), libnss-winbind:amd64 
> (4.3.11+dfsg-0ubuntu0.14.04.14, automatic), samba-common-bin:amd64 
> (4.3.11+dfsg-0ubuntu0.14.04.14, automatic), libldb1:amd64 
> (1.1.24-0ubuntu0.14.04.1, automatic), libtdb1:amd64 
> (1.3.8-0ubuntu0.14.04.1, automatic),
> libfile-copy-recursive-perl:amd64 (0.38-1, automatic),
> samba-libs:amd64 (4.3.11+dfsg-0ubuntu0.14.04.14, automatic),
> libtalloc2:amd64 (2.1.5-0ubuntu0.14.04.1, automatic),
> python-talloc:amd64 (2.1.5-0ubuntu0.14.04.1, automatic),
> libpam-winbind:amd64 (4.3.11+dfsg-0ubuntu0.14.04.14, automatic),
> libwbclient0:amd64 (4.3.11+dfsg-0ubuntu0.14.04.14, automatic),
> samba-vfs-modules:amd64 (4.3.11+dfsg-0ubuntu0.14.04.14, automatic),
> python-ldb:amd64 (1.1.24-0ubuntu0.14.04.1, automatic),
> samba-common:amd64 (4.3.11+dfsg-0ubuntu0.14.04.14, automatic)
> End-Date: 2018-03-19  12:01:23
> 
> But, problem continue.
> 

OK, you seem to have compiled 4.6.3 yourself using
'--prefix=/opt/samba', this will put all of Samba into /opt/samba, so
the next question will have to be, have you altered the PATH ??

If your DC was running on distro packages, then the ldb files that
a Samba DC needs will be in '/var/lib/samba/private'. Your new
installed Samba will be looking in '/opt/samba/private'. 

If you want/need a later Samba version, you will probably be better of upgrading your
distro to 18.04, this will get you 4.7.5

Rowland

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba