Web lists-archives.com

Re: [Samba] samba-tool error just after samba 4.8.0 install




I understand but do you think the work will be done to make it compatible again ?
If not, there should be a statement in the changelog about this broken compatibility.

Christophe Borivant

----- Mail original -----
De: "Andrew Bartlett" <abartlet@xxxxxxxxx>
À: "Christophe BORIVANT" <cborivant@xxxxxxxxxxxx>, "samba" <samba@xxxxxxxxxxxxxxx>
Envoyé: Mercredi 14 Mars 2018 19:57:58
Objet: Re: [Samba] samba-tool error just after samba 4.8.0 install

On Wed, 2018-03-14 at 16:21 +0100, Christophe Borivant via samba wrote:
> Ok, for what i understand, this is a compatibility issue with python 2.6.
> This seems to be in relation with Dict Comprehensions (https://www.python.org/dev/peps/pep-0274/).
> 
> So yet, samba 4.8 cannot run on any rhel 6 like distribution.
> 
> Was it intended ?
> 
> Christophe Borivant

I don't think it was intentional, but it is showing the increasing cost
of maintaining Samba's compatibility with a version of python first
released in 2008!

Andrew Bartlett
-- 
Andrew Bartlett                       http://samba.org/~abartlet/
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba