Web lists-archives.com

Re: [Samba] failed to call wbcSidToUid




2018-03-05 17:44 GMT+01:00 Rowland Penny via samba <samba@xxxxxxxxxxxxxxx>:

> On Mon, 5 Mar 2018 17:34:10 +0100
> Marcin Kruk <askifyouneed@xxxxxxxxx> wrote:
>
> > 2018-03-05 17:28 GMT+01:00 Rowland Penny via samba
> > <samba@xxxxxxxxxxxxxxx>:
> > >
> > > The problem with your old smb.conf working, but not your new one, is
> > > hard to understand because the requirements haven't really changed.
> > > It might help if you could post your old smb.conf
> > >
> > > Rowland
> > >
> > >
> > >
>
> OK, try using these 'idmap config' lines instead of the ones you added:
>
> idmap config * : backend = tdb
> idmap config * : range = 1000000-1999999
> idmap config MYDOMAIN : backend  = rid
> idmap config MYDOMAIN : range = 2000-20000
>
> Rowland
>
>

Now I get everything very clearly.

Of course I had change backend to rid but...

Even when I added backend = rid
I get
failed to call wbcSidToUid: WBC_ERR_DOMAIN_NOT_FOUND
Could not convert sid S-1-5-...-13658 to uid

But the crucial is the last string in the SID from the Microsoft AD
followed by dash -13658
so I needed bigger range like
idmap config DOMAIN : range = 200000-299999

bacause the number 13658 is added to min value 200000 so it is
200000+13658=213658 so the range must be appropriate

Now after:
net cache flush
restart winbind
wbinfo -S S-1-5-...-13658
shows 213658
chown DOMAIN+user1 dir_path

Everytiing works perfectly
I think that it should be more clarify in the SAMBA Active DIrectory
documentation about this process :)

Thank you for your help.
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba