Web lists-archives.com

Re: [Samba] failed to call wbcSidToUid

On Mon, 5 Mar 2018 16:29:43 +0100
Marcin Kruk via samba <samba@xxxxxxxxxxxxxxx> wrote:

> I have samba-4.6.2-12.el7_4.x86_64 which is connected to WIndows
> Active Directory Server.
> When I use command wbinfo -u
> I can see a list of all users in AD domain
> MYDOMAIN+user1
> MYDOMAIN+user2

At least this shows that winbind knows your AD users.

> When I execute
> wbinfo -n user1 or
> wbinfo -n DOMAIN+user
> I get:
> S-1-5-21-... SID_USER (1)
> but when I execute
> wbinfo -S SID
> I get:
> Could not convert sid S-1-5-21-... to uid
> moreover when I try to chown the directory
> chown "DOMAIN+user1" directory_path
> I get:
> chown: invalid user: 'DOMAIN+user1’

Here we go with 1001th time of saying this ;-)

Just because wbinfo shows your users & groups, doesnt mean your OS
knows who they are.

> In the respectively configuration in samba samba-4.4.4-12.el7_3.x86_64
> everything goes ok but configuration is without whole idmap config
> section. Its oldfashion style.
> I do not know mabye "backend = ad" is the problem of this
> configuration. But when I move configuration from the sama 4.4.4-12
> server the problem still exists.

It probably is the 'ad' backend, do your users have a 'uidNumber'
attribute in AD and does 'Domain Users' have a 'gidNumber' attribute ?
These numbers will need to be inside the '1000000-2000000' range you
have set in smb.conf.


To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba