Web lists-archives.com

Re: [Samba] getpwuid failed for single user on single file share




On Wed, 14 Feb 2018 19:05:34 +0100
Arne Zachlod via samba <samba@xxxxxxxxxxxxxxx> wrote:

> Hello,
> 
> I have a problem with my samba installation I can not get my head
> around, maybe some of you have a good idea about what is going on.
> 
> I have a file share called "adfs02" and an AD DC called "addc02" in
> the same site. The error occurs only with this one user, and it
> worked til the last password change of that user two days ago.
> 
> Here are the outputs of my test case (both on done on adfs02):
> 
> root@adfs02:~# smbclient -L localhost -U brokenuser@int.domain
> Enter brokenuser@int.domain's password:
> session setup failed: NT_STATUS_UNSUCCESSFUL
> 
> root@magneto:~# smbclient -L localhost -U arne@int.domain
> Enter arne@int.domain's password:
> Domain=[BECIT] OS=[Windows 6.1] Server=[Samba 4.3.11-Ubuntu]
> ...
> 
> root@magneto:~# smbclient -L addc02.int.becit.de -U
> brokenuser@int.domain Enter brokenuser@int.domain's password:
> Domain=[BECIT] OS=[Windows 6.1] Server=[Samba 4.3.11-Ubuntu]
> ...
> 
> So, as we can see, the broken user is only broken on the domain
> member, but not on the AD DC, how can that be? I tried deleting
> /var/lib/samba/wimbindd_cache.tdb, but it didn't change anything.
> I also checked all the DCs with "samba-tool checkdb", but no errors
> where detected.
> 

I take it that the DCs real name is 'magneto' (HINT: if you are going
to sanitize things, please be consistent)

If you run 'smbclient -L adfs02.int.becit.de -U brokenuser@int.domain'
on 'adfs02', does this work

Does 'getent passwd brokenuser' produce any output when run on 'adfs02'
?

Have you tried changing the password again ?

Rowland

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba