Web lists-archives.com

Re: [Samba] how to upgrade schema version?

On Wed, 14 Feb 2018 18:27:20 +0100
Peter Schmidt via samba <samba@xxxxxxxxxxxxxxx> wrote:

> Hi!
> I'm running samba 4.3.11 on Ubuntu server Xenial. It's the only AD-DC
> in a windows domain that used to be hosted by a single Win2k3 server.
> The AD schema version is 30, the functionality level is already
> raised to 2008_R2 (domain) and 2008 (forest).
> ~# ldbsearch -H /var/lib/samba/private/sam.ldb -b 
> 'cn=Schema,cn=Configuration,dc=domain,dc=com' -s base objectVersion
> # record 1
> dn: CN=Schema,CN=Configuration,DC=vswest,DC=intern
> objectVersion: 30
> Now I cannot access the Domain Controllers via RSAT and the logs show 
> "cannot find attr[msDS-isRODC] in of schema".
> How do I upgrade the schema?

This has happened before, see here:


Don't know if it will help though, you need the schema ldifs


To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba