Web lists-archives.com

Re: [Samba] nmbd error: workgroup name is too long




Louis, thanks for the suggestion. I deleted everything between the “B” in COOMBS and the first “e” in “server” and re-typed it all (including the new line) using nano. I even got rid of all the space (tab) before “server”. 

I restarted samba (including nmbd) and same result.

Kirk 

> On Feb 6, 2018, at 12:42 AM, L.P.H. van Belle via samba <samba@xxxxxxxxxxxxxxx> wrote:
> 
> Open a random text editor. 
> 
> Goto this line : workgroup = COOMBS 
> 
> Press end and remove the spaces behind COOMBS, keep removing untill the line below it moves one up.
> Then hit enter and restart samba. 
> 
> 
> Greetz, 
> 
> Louis
> 
> 
>> -----Oorspronkelijk bericht-----
>> Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens Kirk 
>> Coombs via samba
>> Verzonden: maandag 5 februari 2018 20:47
>> Aan: samba@xxxxxxxxxxxxxxx
>> Onderwerp: [Samba] nmbd error: workgroup name is too long
>> 
>> I found a similar thread in this mailing list from a few 
>> years ago, but it looks like there was never a clear 
>> resolution. 
>> (https://lists.samba.org/archive/samba/2015-February/189450.html).
>> 
>> I’m fairly frequently receiving the following error in my logs:
>> 
>> Feb  5 11:16:22 hal nmbd[19333]: [2018/02/05 11:16:22.889584, 
>> 0] ../source3/nmbd/nmbd_workgroupdb.c:57(name_to_unstring)
>> Feb  5 11:16:22 hal nmbd[19333]:   name_to_nstring: workgroup 
>> name COOMBS         ^[ is too long. Truncating to
>> 
>> I’m running Samba 4.7.4 on FreeBSD 11.1. My smb4.conf file 
>> has the workgroup name as “COOMBS”, with NO trailing spaces. 
>> Here’s the complete configuration file:
>> 
>> [global]
>> 	workgroup = COOMBS
>> 	server string = Samba Server Version %v
>> 	netbios name = HAL
>> 
>> 	security = user
>> 	encrypt passwords = yes
>> 	passdb backend = tdbsam
>> 
>> 	wins support = yes
>> 	domain master = yes
>> 
>> 	interfaces = 192.168.1.220
>> 	bind interfaces only = yes
>> 
>> [Plex]
>> 	path = /zraid/plex
>> 	valid users = plex
>> 	writable = yes
>> 	browsable = yes
>> 	read only = no
>> 	guest ok = no
>> 	create mask = 0666
>> 	directory mask = 0755
>> 
>> In the prior thread, there was speculation of some invisible 
>> control character at play. I typed the above configuration 
>> file manually--with no copy/paste--so that should not be the case.
>> 
>> Note that the error only seems to appear if "domain master = 
>> yes” is set.
>> 
>> The netbios services do see to work—I just get my logs filled 
>> with these errors.
>> 
>> Any suggestions?
>> 
>> Thanks,
>> 
>> Kirk Coombs
>> -- 
>> To unsubscribe from this list go to the following URL and read the
>> instructions:  https://lists.samba.org/mailman/options/samba
>> 
>> 
> 
> 
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba