Web lists-archives.com

Re: [Samba] [Curiosity] 'netbios aliases' works in AD mode?




On Mon, 18 Dec 2017 15:24:16 +0100
Marco Gaiarin via samba <samba@xxxxxxxxxxxxxxx> wrote:

> 
> > Ahem no one reply me.
> 
> Still no feedback. I've done some test by myself.
> 
> a) i've added in smb.conf:
> 
> 	netbios aliases = CUPSSV FILESV
> 
> b) i've registered the alias as SPNs, now i've:
> 
> 	root@vdcsv1:~# samba-tool spn list vdmsv1$
> 	vdmsv1$
> 	User
> CN=VDMSV1,OU=Computers,OU=SanVito,OU=FVG,DC=ad,DC=fvg,DC=lnf,DC=it
> has the following servicePrincipalName: HOST/VDMSV1
> HOST/vdmsv1.ad.fvg.lnf.it HOST/filesv.ad.fvg.lnf.it
> 		 HOST/FILESV
> 		 HOST/CUPSSV
> 		 HOST/cupssv.ad.fvg.lnf.it
> 
> (for google, the correct commandline seems:
> 	samba-tool spn add HOST/cupssv.ad.fvg.lnf.it vdmsv1$
> )
> 
> c) still does not work; if i browse the network i can see the 'FILESV'
>  host/server, but i cannot open it (give a generic/unknown error).
> 
> 
> Could be that there's no DNS records?
> 
> 	root@vdcsv1:~# host filesv.ad.fvg.lnf.it
> 	Host filesv.ad.fvg.lnf.it not found: 3(NXDOMAIN)
> 
> I've to add that, via 'samba-tool dns add'? I've to add 'A' records or
> i can add 'CNAME'?
> 
> 
> Thanks.
> 

I am wondering if you are mixing up netbios and dns here ?
netbios is what the earlier workgroups and NT4-style domains used to
find each other, or in other words 'network browsing'
If you are not using SMB1 (and you really shouldn't be) you will not be
using 'network browsing'.

Why do you think you need 'netbios aliases' ?

Rowland

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba