Web lists-archives.com

Re: [Samba] Windows 98 cannot connect to Samba 3.6.23-45el6 after upgrade from 3.0.33-3.41.el5




On Mon, 2017-12-11 at 15:49 -0500, Justin Cantrell via samba wrote:
> I upgraded a server from CentOS 5 to CentOS 6 and migrated the samba 
> users, accounts, and files. Everyone reconnected without a problem 
> except a Win98 user.
> Is there anything that changed that would disallow a Win98 machine from 
> connecting.
> It doesn't prompt for password.  It just doesn't connect.
> 
> When attempting to map the drive, I get:
> "The following error occurred while trying to connect S: to \\server\folder
> 
> The computer or sharename could not be found. Make sure you typed it 
> correctly and try again."
> 
> No entries in /var/log/messages /var/log/samba/smb.log /var/log/secure
> 
> I can connect on the same subnet with Windows 10 machines using the same 
> credentials.

My first guess is that you need to set:

lanman auth = yes

Naturally this isn't secure, but this is most likely what the issue is.

If not, turn up the logs and see what more detail you can get.  3.6
still uses SMB1 only by default (and this is still on by default even
in modern versions), so it won't be the new SMB2 world.

I hope this helps,

Andrew Bartlett

-- 
Andrew Bartlett
https://samba.org/~abartlet/
Authentication Developer, Samba Team         https://samba.org
Samba Development and Support, Catalyst IT   
https://catalyst.net.nz/services/samba





-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba