Web lists-archives.com

Re: [Samba] sendmail getting domain\user as email userId




On Thu, 30 Nov 2017 17:09:56 +0000 Rowland Penny <rpenny@xxxxxxxxx> wrote:
>
[deleted]
> > Comments:
> > 
> > This "bug" has been hanging around in Samba since April, 2013,
> > https://bugzilla.samba.org/show_bug.cgi?id=9780 It is currently
> > marked as RESOLVED FIXED by Andrew Bartlett of as 2016-07-28, but it
> > is clearly not solved. Anyone running `getent passwd` or `wbinfo` on
> > the AD/DC will get "DOMAIN/user" instead of "user". Therefore, not
> > solved.
> > 
> > This functionality is inconsistent with the values returned by the
> > same commands on a domain member. 
> > 
> > It currently breaks authentication for various facilities on the
> > AD/DC, not limited to mail MTAs and MDAs. 
> > 
> > I've found a number of postings on this list about this problem.
> > Some people, (Mike E. (posting Thu Jul 21 12:30:40 2016) have found
> > other work-arounds including using sssd in nsswitch.conf instead of
> > winbind.  There are 10 postings on the bug report for people having
> > the same problem including another (Luc Lalonde) who also switched to
> > sssd. 
> > 
> > I believe this is a problem in the real-world and should be more
> > urgently addressed by the Samba team. I think this is a fundamental
> > piece of Samba4 and it should work correctly.
> > 
> > My two cents worth.
> > 
> > --Mark
> > 
> > -----Original Message-----
> > Date: Wed, 29 Nov 2017 10:48:06 -0500
> > To: samba@xxxxxxxxxxxxxxx
> > Subject: Re: [Samba] sendmail getting domain\user as email userId
> > 
> > [deleted]
> > 
>
> I have re-opened the bug report, the problem is that the devs don't see
> it as a problem, whilst a lot of users do :-(
>
> Rowland
>

Thanks Rowland. As a developer myself, I generally consider my users problems to be MY problems!

--Mark

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba