Web lists-archives.com

Re: [Samba] Trouble during classicupgrade




On Sat, 25 Nov 2017 16:49:24 +0100
Andreas Heinlein via samba <samba@xxxxxxxxxxxxxxx> wrote:

> Hello,
> 
> I need to do a classic migration on a machine which has until now been
> running samba as an old NT4-style PDC. I made a copy of that machine
> in a VM to test the process. Until now, things don't work quite
> right. I was following the classic upgrade howto from wiki.samba.org.
> I was using the method with internal DNS. Classicupgrade itself ran
> without errors, I followed the steps after provisioning in the setup
> guide until the connection test with smbclient:
> 
> smbclient -L localhost -U%
> session setup failed: NT_STATUS_INTERNAL_ERROR

I have just discovered there was a link error on the 'classic upgrade'
page (now fixed), it took you to the entire page instead of the
relevant section, so how much of the page did you follow ?

> 
> With log level raised to 5, I can find in log.smbd:
> 
> [2017/11/25 16:41:48.248479,  1]
> ../source3/smbd/sesssetup.c:290(reply_sesssetup_and_X_spnego)
>   Failed to generate session_info (user and group token) for session
> setup: NT_STATUS_INTERNAL_ERROR
> 
> Turning log level to 10 I get an awful lot of info, including several
> messages:
> 
> Duplicate base-DN matches found for <SID=1-5-11>

This is 'Authenticated Users' and is stored in AD as
'CN=S-1-5-11,CN=ForeignSecurityPrincipals,DC=samdom,DC=example,DC=com'
and should only be found once.

Rowland

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba