Web lists-archives.com

Re: [Samba] The group name could not be found




On 18 November 2017 at 19:08, Ian Coetzee <samba@xxxxxxxxxxxxxxxxx> wrote:

> Hey guys,
>
> It's me again.
>
> Today I moved our NAS from our old 2000 domain to a new domain presided
> over by two Samba 4.7.2 domain controllers.
>
> After the move I cant access the NAS at all from my Windows 7 test pc. I
> keep getting an error that "The group name could not be found"
>
> I am at the end of my troubleshooting skills.
>
> I also moved the NAS' samba from sernet-samba 4.1 to the CentOS 6.9
> packaged version 4.2.10.
>
> I also cleaned out the /var/lib/samba/* and rejoined the NAS the new
> domain, still to no avail.
>
> The only thing I could pick out from the logs:
> [2017/11/18 19:02:01.550190,  1, pid=7693, effective(0, 0), real(0, 0)]
> ../librpc/ndr/ndr.c:439(ndr_print_function_debug)
>        wbint_LookupName: struct wbint_LookupName
>           out: struct wbint_LookupName
>               type                     : *
>                   type                     : SID_NAME_USE_NONE (0)
>               sid                      : *
>                   sid                      : S-0-0
>               result                   : NT_STATUS_NONE_MAPPED
>
> However from one of the dc's:
> $ wbinfo -s S-0-0
> failed to call wbcStringToSid: WBC_ERR_INVALID_SID
> Could not lookup sid S-0-0
>
> $ wbinfo -n ianc
> S-1-5-21-2093009959-3443338361-3281248646-1407 SID_USER (1)
>
> $ wbinfo --user-domgroups=S-1-5-21-2093009959-3443338361-3281248646-1407
> S-1-5-21-2093009959-3443338361-3281248646-1407
> S-1-5-21-2093009959-3443338361-3281248646-513
> S-1-5-21-2093009959-3443338361-3281248646-512
> S-1-5-21-2093009959-3443338361-3281248646-572
> S-1-5-21-2093009959-3443338361-3281248646-2189
> S-1-5-21-2093009959-3443338361-3281248646-2208
>
> Anybody got another idea I could try, or somewhere I am overlooking?
>
> Kind regards
>


Hey guys,

Some more information, from dc1:
$ smbclient //nas/IPC$
Enter SAMDOM\ianc's password:
Try "help" to get a list of possible commands.
smb: \> exit

$ smbclient //nas/IT
Enter SAMDOM\ianc's password:
tree connect failed: NT_STATUS_NO_SUCH_GROUP

I guess that means the problem is with my smb.conf.

Kind regards
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba