Web lists-archives.com

Re: [Samba] Curious: Schema refresh needed 1 != 2




On 16 November 2017 at 13:15, Rowland Penny via samba <samba@xxxxxxxxxxxxxxx
> wrote:

> On Thu, 16 Nov 2017 12:55:06 +0200
> Ian Coetzee <samba@xxxxxxxxxxxxxxxxx> wrote:
>
> > On 16 November 2017 at 10:29, Rowland Penny <rpenny@xxxxxxxxx> wrote:
> > > On Thu, 16 Nov 2017 08:40:01 +0200
> > > Ian Coetzee via samba <samba@xxxxxxxxxxxxxxx> wrote:
> > >
> > >> Hi Rowland,
> > >>
> > >> > How did you upgrade ?
> > >>
> > >> I upgraded by merging the latest code from the samba git repo,
> > >> doing a git clean to remove old local files. Then using a set of
> > >> scripts (outside the samba git folder) I compile the code into a
> > >> rpm which then gets redistributed internally to our DC's, running
> > >> CentOS 6.9 (All packages up to date)
> > >>
> > >> > Have you upgraded everything ?
> > >>
> > >> I am not quite sure what you mean by this. I assume:
> > >>
> > >> $ wbinfo -V
> > >> Version 4.7.2
> > >>
> > >> $ smbclient -V
> > >> Version 4.7.2
> > >>
> > >> $ samba-tool -V
> > >> 4.7.2
> > >>
> > >> Kind regards
> > >>
> > >
> > > ldbsearch -V
> >
> > Hi Rowland
> >
> > $ ldbsearch -V
> > Version 4.7.2
> >
> > Kind regards
> > >
> > > Rowland
>
> The message seems to be coming from here:
>
> source4/dsdb/samdb/ldb_modules/schema_load.c [line 218]
>
>         if (schema != NULL) {
>                 if (ret == LDB_SUCCESS) {
>                         if (schema->metadata_usn == schema_seq_num) {
>                                 TALLOC_FREE(mem_ctx);
>                                 return schema;
>                         } else {
>                                 DEBUG(3, ("Schema refresh needed %lld !=
> %lld\n",
>                                           (unsigned long
> long)schema->metadata_usn,
>                                           (unsigned long
> long)schema_seq_num));
>                         }
>                 } else {
>
>
> I wouldn't use Samba from git in production, I would use the latest
> available tarball.
> If everything is working okay, you could use 'log level = 2' in
> smb.conf, this should turn off the messages. It wont fix the problem
> though, which seems to be a problem with the schema.
>
> Rowland
>
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba
>

I am using Samba from the stable branch, I am not that adventurous :)

Both dc's on 4.7.2

So far all is holding steady, no adverse issues reported.

Thank you for checking :)
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba