Web lists-archives.com

Re: [Samba] Unable to upload printer drivers




	Hello Louis,


Le 06/11/2017 à 11:22, L.P.H. van Belle via samba a écrit :

I normaly onlu use windows 7, since that works fine for me, but i'll setup a win10 and give it a try.

Ok, cool.

My cups server publishes x64 by default and you need a win32 and a win64 pc to upload both drivers.

Yes I know this, see below.

Now, this is something you can try and i'll explain what is difference in my setup.
Most users dont use spoolss and dont use the architecture setttings.
     rpc_server:spoolss = external
     rpc_daemon:spoolssd = fork
     spoolss:architecture = Windows x64

I gave my smb.conf in my first mail and I've got this lines, I strictly followed the wiki.
And also tried without, and same error uploading 32 bit driver.


There as a "historyical" bug, about lower and uppercased characters in (Debian) /var/lib/samba/printers/
I symlinked very folder lower to uppercase, now this bug was i believe on the X64/x64, but i did them all.

Yes, i saw an old thread where you proposed that. Also tried this... and same error. But we can see that it tries to copy to x64 folder.

And randomly sometimes there is a second error WERR_ACCESS_DENIED (with administrator account or domain admins account) who have full rights.

Nov 6 12:09:01 winix-test-ps2 smbd[465]: [2017/11/06 12:09:01.240015, 0, pid=465, effective(0, 0), real(0, 0)] ../source3/printing/nt_printing.c:1144(move_driver_file_to_download_area) Nov 6 12:09:01 winix-test-ps2 smbd[465]: move_driver_file_to_download_area: Unable to rename [x64/{D1FB7FC7-C3D6-44BE-99F4-069DC8C66642}/eSf6usf_builtin.dll] to [x64/3/eSf6usf_builtin.dll]: NT_STATUS_SHARING_VIOLATION Nov 6 12:09:01 winix-test-ps2 smbd[465]: [2017/11/06 12:09:01.240123, 0, pid=465, effective(0, 0), real(0, 0), class=rpc_srv] ../source3/rpc_server/spoolss/srv_spoolss_nt.c:8614(_spoolss_AddPrinterDriverEx) Nov 6 12:09:01 winix-test-ps2 smbd[465]: _spoolss_AddPrinterDriverEx: move_driver_to_download_area failed - WERR_ACCESS_DENIED


And another thing illogical :

As i said, i can upload drivers without problem with w7, but i can't see the printers, despite with firefox of my windows i can see them... Did you do something particular to see printers under seven ?

So i'm juggling w7 and w10... w7 to upload drivers and w10 to assign driver to the printer.

So finally, i can finalize my setup, but i like understanding what I'm doing and the origin of problems :-)


Thanks again Louis.

Regards,

--
Manu





--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba