Web lists-archives.com

Re: [Samba] Unable to upload printer drivers




Hai Manu, 



> -----Oorspronkelijk bericht-----
> Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens Manu 
> Baylac via samba
> Verzonden: vrijdag 3 november 2017 20:21
> Aan: samba@xxxxxxxxxxxxxxx
> Onderwerp: Re: [Samba] Unable to upload printer drivers
> 
> 	Hello Louis and list,
> 
> 
> Le 03/11/2017 à 10:25, L.P.H. van Belle via samba a écrit :
> 
> > Sorry for the slow reaction here. I was few days out of the office.
> 
> No problem, thanks for your quick answer.
> 
> > But can you try the universal 2 driver. That one works fine for me.
> > And if you send me the exact driver your trying to me, i'll 
> test that one in my setup.
> 
> In my second mail, i said that finally i successfully installed the 
> driver... but only once...
> i deleted the driver, reinstalled and... same error.
You might have hit a bug here.

> 
> After hours and near becoming crazy (because it is a very 
> basic setup), 
> trying to reproduce the problem before responding, i finally 
> installed a 
> win7 and...booo...no problem, works fine with all drivers...
> 
> I'm not a windows user, so i downloaded win10 from microsoft website 
> for my platform test since now it's possible. And in the 
> school where i get the exactly same error, they have official windows10 with 
> purchased licenses.
> So a friend gave me an official iso of W7 to test in the same 
> context on 
> my platform and it works like a charm, i didn't change anything in my 
> configuration.
> 
> The driver i used is the one you mentioned (i wrote type 3 because on 
> the wiki page the term is used and the full error on windows 
> side is : 
> impossible to install Toshiba Universal Printer2, type3 - 
> user mode, x64 
> access denied). The only available driver on toshiba official site is 
> W2012/8.1/8, but i think it is compatible with w10 since this 
> printer is 
> still proposed by suppliers.
> 
> So, Louis, do you tested under windows10 ??? The problem is 
> that in the 
> school they use windows10 so i must find the solution.
I normaly onlu use windows 7, since that works fine for me, but i'll setup a win10 and give it a try. 

My cups server publishes x64 by default and you need a win32 and a win64 pc to upload both drivers.
Atm i only do 64bit drivers since i dont have any 32bit os running anymore. 

> 
> And what does mean NT_STATUS_SHARING_VIOLATION error ?
I this this is related to :  access denied  


Now, this is something you can try and i'll explain what is difference in my setup. 
Most users dont use spoolss and dont use the architecture setttings. 
    rpc_server:spoolss = external
    rpc_daemon:spoolssd = fork
    spoolss:architecture = Windows x64

Now, since you number ... Somany who says its not working and here it is, ive done a good checka again in my setup.
( the install if from 2015, as of samba 4.2 )
There as a "historyical" bug, about lower and uppercased characters in (Debian) /var/lib/samba/printers/

The good layout, untouched as of 2016.
root@rtd-print1:~# ls -al /var/lib/samba/printers/
drwxr-xr-x  2 root root 4096 Mar 11  2016 COLOR
drwxr-xr-x  2 root root 4096 Mar 11  2016 IA64
drwxr-xr-x  2 root root 4096 Mar 11  2016 W32ALPHA
drwxr-xr-x  2 root root 4096 Mar 11  2016 W32MIPS
drwxr-xr-x  2 root root 4096 Mar 11  2016 W32PPC
drwxr-xr-x  2 root root 4096 Mar 11  2016 W32X86
drwxr-xr-x  2 root root 4096 Mar 11  2016 WIN40
drwxr-xr-x  2 root root 4096 Mar 11  2016 x64

But this is what im using ( since aug 2015 )
I symlinked very folder lower to uppercase, now this bug was i believe on the X64/x64, but i did them all. 

root@rtd-print1:~# ls -al /home/samba/printers/
drwxr-xr-x   4 root root 4096 Aug  7 10:35 ..
lrwxrwxrwx   1 root root    5 Aug  2  2016 color -> COLOR
drwxrwx---+  2 root root 4096 Aug  6  2015 COLOR
lrwxrwxrwx   1 root root    4 Aug  2  2016 ia64 -> IA64
drwxrwx---+  2 root root 4096 Aug  6  2015 IA64
drwxrwx---+  2 root root 4096 Aug  6  2015 W32ALPHA
lrwxrwxrwx   1 root root    7 Aug  2  2016 w32mips -> W32MIPS
drwxrwx---+  2 root root 4096 Aug  6  2015 W32MIPS
lrwxrwxrwx   1 root root    6 Aug  2  2016 w32ppc -> W32PPC
drwxrwx---+  2 root root 4096 Aug  6  2015 W32PPC
lrwxrwxrwx   1 root root    6 Aug  2  2016 w32x86 -> W32X86
drwxrwx---+  4 root root 4096 Oct 24  2016 W32X86
lrwxrwxrwx   1 root root    5 Aug  2  2016 win40 -> WIN40
drwxrwx---+  2 root root 4096 Aug  6  2015 WIN40
drwxrwx---+  3 root root 4096 Oct 10 09:59 x64
lrwxrwxrwx   1 root root    3 Aug 18  2016 X64 -> x64

At least a thing you can try.

> 
> Ah, and when i try to upload under w10 the 32 bits driver, 
> same error on 
> windows but the NT_ error doesn't appear in syslog.
> 
> Here is what can i say...with my poor english, sorry.
Ah, well its as good as mine ;-) 

> 
> Any suggestion ?
> 
> Thanks !
> 
> Regards,
> 
> --
> Manu

Greetz, 

Louis


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba