Web lists-archives.com

Re: [Samba] Share mounts in SMBv1 mode, but fails weirdly in SMBv2 mode




On Thu, Oct 12, 2017 at 03:58:58PM +0200, Hadrien Grasland via samba wrote:
> Hi,
> 
> We're slowly deprecating SMBv1 support at work, so I'm trying to
> mount our Samba network shares using SMBv2.0. This should in
> principle be supported by the server, and seems works well enough
> for the Windows clients. But it fails for me with some errors which
> I do not understand.
> 
> Can you help me figure out what's going on? Here's my system
> configuration and a quick summary of what I have so far:
> 
> hadrien@linux-2ak3:~> uname -a
> Linux linux-2ak3 4.13.5-1-default #1 SMP PREEMPT Thu Oct 5 18:28:26
> UTC 2017 (3fd9659) x86_64 x86_64 x86_64 GNU/Linux
> hadrien@linux-2ak3:~> /sbin/mount.cifs --version
> mount.cifs version: 6.5
> hadrien@linux-2ak3:~> sudo mount -v -t cifs //nfsserv22/expsi test
> -o credentials=<path to credentials file>,vers=2.0
> domain=LAL
> mount.cifs kernel mount options: ip=134.158.91.155,unc=\\nfsserv22\expsi,vers=2.0,user=grasland,,domain=LAL,pass=********
> mount error(95): Operation not supported
> Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
> hadrien@linux-2ak3:~> dmesg | tail
> [...]
> [13424.783242] CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2
> [13424.789504] CIFS VFS: cifs_read_super: get root inode failed
> 
> Replacing "vers=2.0" with "vers=1.0" in the mount command line makes
> this work, so I'm quite confident that my general configuration is
> correct and the problem is somehow specific to the SMBv2 protocol.
> However, I'm a Samba newbie and would welcome any tips on how to
> extract more information from this machine/server in order to figure
> out why SMBv2 specifically is failing.

Can you get a wireshark trace on port 445 between client and
server ? That would help.

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba