Web lists-archives.com

Re: [Samba] Samba 4.7.0




On Tue, 10 Oct 2017 15:48:13 +0000
"Mogane, Ratanang Johannes, Vodacom South Africa (External)"
<Ratanang.Mogane@xxxxxxxxxxxxxxxxx> wrote:

> Hi Rowland,
> 
> I have run :
> ./configure
> 
> And at the end the following messages were found which means it needs
> the dependency. Correct?
> 
> /opt/samba-4.7.0/source4/lib/tls/wscript:51: error: Building the AD
> DC
> requires
> GnuTLS (eg libgnutls-dev, gnutls-devel) for ldaps:// support and for
> the
> BackupK
> ey protocol root@tccoll01 #
> 
> Is this now mean it need the Package Dependencies Required to Build
> Samba? If yes, under there I don't see for unix/Solaris. I see for
> linux/Red Hat/ etc
> 
> Regards
> Ratanang
> 

You are brave and quite possibly a pioneer, Your OS isn't listed on
the page you refer to, because I don't think anybody has tried to build
an AD DC on Solaris 11 before.

You are quite correct, the error message does say you have a missing
dependency, in this case, you need the Solaris 11 version of
libgnutls-dev. You will need to install this and then re-run
configure, if you then get any more failures, you will need to
identify and install any other missing packages.

Whilst you might be able to build the Samba software, you will not get
much further if your filesystem doesn't understand POSIX ACLs, the
provision of a DC will fail.

You will probably also get problems with the compiler if it isn't
similar to the Linux compiler.

If you do get it to build, you will find Samba in /usr/local/samba

Good luck

Rowland
 

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba