Web lists-archives.com

Re: [Samba] samba getting stuck, highwatermark replication issue?




On 10/10/2017 3:14 AM, mj via samba wrote:
Hi James,

Thanks for the quick reply.

On 10/09/2017 08:52 PM, lingpanda101 via samba wrote:

You should be able to fix the 'replPropertyMetaData' errors with;

samba-tool dbcheck --cross-ncs --fix --yes 'fix_replmetadata_unsorted_attid'
Yep, worked great! Fixed all of those replPropertyMetaData errors! :-)

The highwatermark doesn't necessarily reflect an issue. It's part of how the destination DC keeps track of changes from the source DC. Can you verify the time and date is correct on all DC's?
Date & time matches. But the fact that the same identical message is logged multiple times per second, without an end seems a bit strange... Combined with high cpu usage on the DC where this happens. (yesterday DC2, currently on DC4)

The GUID errors seem related to your old DC offline and NTDS connections still lingering.  Open Microsoft Sites and Services and remove the ones no longer needed.
There is no DC1 mentioned anywhere there. And the two errors remain:

ERROR: no target object found for GUID component for msDS-NC-Replica-Locations in object CN=84bea0a7-82dd-4237-9296-030573700698,CN=Partitions,CN=Configuration,DC=samba,DC=merit,DC=unu,DC=edu - <GUID=81a27497-bdfb-4977-9874-675bbfba490f>;<RMD_ADDTIME=130405075610000000>;<RMD_CHANGETIME=130405075610000000>;<RMD_FLAGS=0>;<RMD_INVOCID=556b2cb4-e576-48e2-bb7c-7f62caee84fc>;<RMD_LOCAL_USN=4605>;<RMD_ORIGINATING_USN=3630>;<RMD_VERSION=0>;CN=NTDS Settings,CN=DC1,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=samba,DC=merit,DC=unu,DC=edu
Not removing dangling forward link
ERROR: no target object found for GUID component for msDS-NC-Replica-Locations in object CN=d9d76e21-8cae-457d-b212-6cb192612739,CN=Partitions,CN=Configuration,DC=samba,DC=merit,DC=unu,DC=edu - <GUID=81a27497-bdfb-4977-9874-675bbfba490f>;<RMD_ADDTIME=130405075610000000>;<RMD_CHANGETIME=130405075610000000>;<RMD_FLAGS=0>;<RMD_INVOCID=556b2cb4-e576-48e2-bb7c-7f62caee84fc>;<RMD_LOCAL_USN=4579>;<RMD_ORIGINATING_USN=3631>;<RMD_VERSION=0>;CN=NTDS Settings,CN=DC1,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=samba,DC=merit,DC=unu,DC=edu
Not removing dangling forward link

I was asked a question during the samba-tool dbcheck:

Add yourself to the replica locations for DC=DomainDnsZones,DC=samba,DC=company,DC=com? [y/N/all/none] N Not fixing missing/incorrect attributes on DC=DomainDnsZones,DC=samba,DC=company,DC=com

Add yourself to the replica locations for DC=ForestDnsZones,DC=samba,DC=company,DC=com? [y/N/all/none] N Not fixing missing/incorrect attributes on DC=ForestDnsZones,DC=samba,DC=company,DC=com

Should I answer Yes to those two questions?

MJ

MJ,

    I must have missed this snipit on your first email.

"Not removing dangling forward link"

These are deleted NTDS and harmless. However you can clean them up with.

#samba-tool domain tombstones expunge

It should be safe to say yes to those questions. You could also run the following command as well for those.

#samba-tool dbcheck --cross-ncs --fix --yes 'fix_replica_locations'

It may be best to run a manual full replication from a good DC to one that is having the problems. See https://wiki.samba.org/index.php/Manually_Replicating_Directory_Partitions


--
--
James

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba