Web lists-archives.com

Re: [Samba] A lot of zombie processes on Debian 9




2017-09-25 15:16 GMT+02:00 L.P.H. van Belle via samba <samba@xxxxxxxxxxxxxxx
>:

> Hai,
>
> Did you check the systemd units? ( not left overs from other versions? )
> Is this a member of ADDC ? ) process shows [samba] so im asumming a member
> server.
>
> And what parameters are used, did you add --with-systemd ?
> and on debian DONT use :  --with-system-mitkrb5
> Debian used Heimdal kerberos ( centos/RH MIT ).
>
> Greetz,
>
> Louis
>
>
>
> > -----Oorspronkelijk bericht-----
> > Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens
> > Daniel Carrasco via samba
> > Verzonden: maandag 25 september 2017 15:00
> > Aan: samba@xxxxxxxxxxxxxxx
> > Onderwerp: [Samba] A lot of zombie processes on Debian 9
> >
> > Hello,
> >
> > I've compiled Samba 4.7 from repository using a Debian 9
> > machine and I've noticed that the system started to create
> > zombie processes of samba:
> >
> > # ps aux |grep "Z"
> > USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START
> > TIME COMMAND
> > root       502  0.0  0.0      0     0 ?        Z    13:01
> > 0:00 [samba]
> > <defunct>
> > root      1346  0.0  0.0      0     0 ?        Z    13:11
> > 0:00 [samba]
> > <defunct>
> > root      2088  0.0  0.0      0     0 ?        Z    13:21
> > 0:00 [samba]
> > <defunct>
> > root      2819  0.0  0.0      0     0 ?        Z    13:31
> > 0:00 [samba]
> > <defunct>
> > root      3541  0.0  0.0      0     0 ?        Z    13:41
> > 0:00 [samba]
> > <defunct>
> > root      4269  0.0  0.0      0     0 ?        Z    13:51
> > 0:00 [samba]
> > <defunct>
> > root      5015  0.0  0.0      0     0 ?        Z    14:01
> > 0:00 [samba]
> > <defunct>
> > root      5753  0.0  0.0      0     0 ?        Z    14:11
> > 0:00 [samba]
> > <defunct>
> > root      6503  0.0  0.0      0     0 ?        Z    14:21
> > 0:00 [samba]
> > <defunct>
> > root      7213  0.0  0.0      0     0 ?        Z    14:31
> > 0:00 [samba]
> > <defunct>
> > root      7932  0.0  0.0      0     0 ?        Z    14:41
> > 0:00 [samba]
> > <defunct>
> >
> >
> > I've got more than 300 samba zombie processes last time, but
> > I don't know what's the problem.
> > I've the same samba version compiled on a Debian 8 machine
> > and is working fine.
> >
> > someone had a simiar problem?
> >
> > Thanks!!
> >
> > --
> > _________________________________________
> >
> >       Daniel Carrasco Marín
> >       Ingeniería para la Innovación i2TIC, S.L.
> >       Tlf:  +34 911 12 32 84 Ext: 223
> >       www.i2tic.com
> > _________________________________________
> > --
> > To unsubscribe from this list go to the following URL and read the
> > instructions:  https://lists.samba.org/mailman/options/samba
> >
>
>
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba



Hello, thanks for your response.

It's a DC server (both, debian 8 and debian 9 servers are DC's together).

The configure command line I've used is:
./configure --enable-gnutls --with-gpgme --with-static-modules=ALL
--with-systemd --prefix='/server/samba/bin/'
--sysconfdir='/server/samba/conf/'

and my systemd file is:
[Unit]
Description=Samba Active Directory Domain Controller
After=network.target remote-fs.target nss-lookup.target

[Service]
Type=forking
ExecStart=/server/samba/bin/sbin/samba -D
PIDFile=/server/samba/bin/var/run/samba.pid

[Install]
WantedBy=multi-user.target


I've built both with same configuration and I use the same Systemd file. Of
course I've compiled every samba on their machine and is not a copy from
one to other.

Thanks!!
-- 
_________________________________________

      Daniel Carrasco Marín
      Ingeniería para la Innovación i2TIC, S.L.
      Tlf:  +34 911 12 32 84 Ext: 223
      www.i2tic.com
_________________________________________
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba