Web lists-archives.com

Re: [Samba] Recycle Repository Issue





On 31.08.2017 16:18, L.P.H. van Belle via samba wrote:
> Hai,
>
> Now, i must say, i know nothing about freebsd or zfs.
> But try these in this order, check what you also use in you global config.
>
> vfs objects = zfs_space zfsac catia fruit recycle streams_xattr aio_pthread
> This should be Zfs and mac compatible.
That did not work at all. My share went offline when I did that.

>
> There was a bug which had todo with the loading order of the vfs modules.
> But if im wrong here, i hope someone on the list corrects me.
>
> Last, in the recycle lines, what happens if you change
> recycle:repository = /tank/recycle
> To
> recycle:repository = /tank/recycle/%U
That did not work either. It just created a folder named 
"/tank/recycle/scilek" with nothing inside it.
>
>
> Greetz,
>
> Louis
>
>
>> -----Oorspronkelijk bericht-----
>> Van: samba [mailto:samba-bounces@xxxxxxxxxxxxxxx] Namens
>> Selahattin Cilek via samba
>> Verzonden: donderdag 31 augustus 2017 13:26
>> Aan: samba@xxxxxxxxxxxxxxx
>> Onderwerp: [Samba] Recycle Repository Issue
>>
>> I have done some searching on the Internet, but not been able
>> to find a solution to my problem. I hope you can help me with this.
>>
>>
>> I have a server at home that runs on FreeBSD 10.3. The file
>> system is ZFS. I have two ZFS pools: tank and fun. I share my
>> ZFS file systems using Samba v4.6.2.
>>
>> When I add recycle bin functionality for a share like below,
>> it work like a charm:
>>
>> [mac]
>>      path = /fun/mac
>>      user = scilek
>>      write list = scilek
>>      writeable = yes
>>      vfs objects = recycle
>>      recycle:repository = .recycle
>>      recycle:versions = Yes
>>
>>
>> But when I try to gather my recycled files in another folder,
>> it does not work:
>>
>> [mac]
>>      path = /fun/mac
>>      user = scilek
>>      write list = scilek
>>      writeable = yes
>>      vfs objects = recycle
>>      recycle:repository = /tank/recycle
>>      recycle:versions = Yes
>>
>>
>> There are no error messages or warnings either. Why does this
>> happen? How can I solve this problem?
>>
>>
>>
>>
>>
>>
>>
>>
>> [https://ipmcdn.avast.com/images/icons/icon-envelope-tick-roun
>> d-orange-animated-no-repeat-v1.gif]<https://www.avast.com/sig-
>> email?utm_medium=email&utm_source=link&utm_campaign=sig-email&
>> utm_content=emailclient>      Virus-free.
>> www.avast.com<https://www.avast.com/sig-email?utm_medium=email
>> &utm_source=link&utm_campaign=sig-email&utm_content=emailclient>
>> --
>> To unsubscribe from this list go to the following URL and read the
>> instructions:  https://lists.samba.org/mailman/options/samba
>>
>


---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba