Web lists-archives.com

Re: [Samba] Samba 4.7rc4. (Debian Stretch Amd64 packages/sources available)




On Fri, 2017-08-18 at 11:11 +0200, L.P.H. van Belle wrote:
> > -----Oorspronkelijk bericht-----
> > Van: Andrew Bartlett [mailto:abartlet@xxxxxxxxx] 
> > Verzonden: donderdag 17 augustus 2017 20:57
> > Aan: L.P.H. van Belle; samba@xxxxxxxxxxxxxxx
> > Onderwerp: Re: [Samba] Samba 4.7rc4. (Debian Stretch Amd64 
> > packages/sources available)
> > 
> > On Thu, 2017-08-17 at 12:35 +0200, L.P.H. van Belle via samba wrote:
> > > Can anyone ( one of the devs)  tell if its safe for a samba 
> > 
> > 4.7rc4 to join and samba 4.6(.7) AD DC domain. 
> > 
> > I have no particular concerns about doing that.  
> 
> Ok, great, i'll go test more things for these  4.7rc (MIT-enabled) packages. 
> A question on this, to be sure, if added, will it upgrade my samba DB or is it staying at 4.6 level.
> Or how is determent when the samba db is upgraded when you add a new DC. 
> When a higer samba version is added? or when the dc with FSMO DC is upgrade? 
> I know its against recommendations to run different versions of the DC's. 

The DB of the new domain will be in a slightly new (but backward
compatible) format.  The domain isn't upgraded.  We may have a
functional level upgrade tool in the future, but currently all Samba
domains (at the same FL from provision time) are essentially the same
across versions since 4.0.2 (or so). 

> > On your configure line:
> > 
> > >                 --with python2,python3
> 
> To my believe, it do what i says, --with python2,python3  enable python 2 and 3 support. 

I think you want:

--extra-python=/usr/bin/python3


> I hoped to be safe with this, keep python2 support and enable 3 also. 
> Jessie also had 2.7 and 3.4 but it defaults to 2.7. 
> The debian wiki is a bit unclear about stretch 2.7 and 3.5 but the default is left out. :-( 
> https://wiki.debian.org/Python 
> 
> If im interpeting that wrong, then i would like to know the preffered python for samba 4.7 (python 2.7 or 3.5) 
> I saw on technical some thing going to python 3 but this debian build still used 2.7. 
> So im bit unclear about this. 

Python 2 is the only supported python for the AD DC.  Python 3 support
is under development, and supports some things, particularly for
FreeIPA.

> > > I'm not sure what you think that does.  I'm not aware of that 
> > 
> > being a valid syntax.
> > 
> > Finally, while you may do what you like with your packages, the MIT
> > Krb5 KDC should not be enabled for the official Debian 
> > packages if you are hoping to propose them there, as RODC 
> > support is not available with the MIT KDC. 
> 
> Yes, i know wbout het missing PKINIT RODC and S4u2... Support.  ( im not useing that as far as i know.)
> I did read the "WHATSNEW" ;-)  and no, these will not go to official debian. 
> At least not the mit version. This samba 4.7rc4 with MIT support stays in my personal repo.
> It gives people at least the option to (more easy) test things bit more quickly for 4.7
> but thank you for pointing this out. 
> 
> Now i can make a new one also with heimdal support, to keep inline with the official debian and a -MIT version to test with. 
> 
> 
> Thanks for you time and knowledge... 

Thanks for your time on the Debian packages.

Andrew Bartlett

> Greetz, 
> 
> Louis
> 
> 
> 
> 
> 
-- 
Andrew Bartlett                       http://samba.org/~abartlet/
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba