Web lists-archives.com

Re: [Samba] extremely low performance on Samba 4.2.14-Debian




Hai, 

Ok, so you have 3 the same machines and only one is slow. Thats important info. 
Did anything special happen with this server. 
For example 2 servers got a new install and this one had an upgrade (or sort of upgrade) from the "old" server? 

Or you configured the new server in an other (ad site) and moved it to the new location. 
In tring to figure out, where what happend, so we can review these steps and point of pitfalls. 

Can you describe the steps you took when you 
- installed a the "problem" new server.
- how you upgraded and/or installed new. 
- was the server move from site to other site ( ! In the AD ) 
- did it have an ip number change when you moved it to the other site.
- did you make backups on the old and restored them on the new? 
( if yes, what and where ) 

You steps, and preffered in order you did them. If you able to recall them all.  ;-) 

If you have 3 (exact) the same machines, and all are same hardware. 
Then or one has failing hardware, or something got corrupted. 

So any info can help more. 

Greetz, 

Louis




> -----Oorspronkelijk bericht-----
> Van: Emmanuel Florac [mailto:eflorac@xxxxxxxxxxxxxx] 
> Verzonden: donderdag 17 augustus 2017 14:01
> Aan: L.P.H. van Belle via samba
> CC: L.P.H. van Belle
> Onderwerp: Re: [Samba] extremely low performance on Samba 
> 4.2.14-Debian
> 
> Le Wed, 16 Aug 2017 23:28:08 +0200
> "L.P.H. van Belle via samba" <samba@xxxxxxxxxxxxxxx> écrivait:
> 
> > > Bios raid/hdds/mainboard up to date, so changelog review 
> cant harm. 
> > > Is the nic using firmware?
> > > The output of :   
> > ethtool -i
> > 
> > So few thing, i can think of i would check. 
> > Its a pain, special when its far, the samba options are thing you 
> > might be able to remotely check. Maybe it helps a bit.
> > 
> 
> I've checked everything round and round. Speed is normal with 
> FTP, but not with Samba (I have no other Linux machine on the 
> network to test NFS). iperf3 proves that the NICs perform 
> normally. I've tested several kernels, 2 different NICs 
> (Silicom 40G and Myri 10G), same low samba performance. 
> 
> I've built 3 machines on the same configuration (same RAID 
> controller, Myri 10G nics, Xeon 6420, 64 GB RAM, same mobo, 
> etc) and only this one is so slow. But only with Samba, 
> everything else performs normally.
> 
> It's really crazy.
> 
> --
> --------------------------------------------------------------
> ----------
> Emmanuel Florac     |   Direction technique
>                     |   Intellique
>                     |	<eflorac@xxxxxxxxxxxxxx>
>                     |   +33 1 78 94 84 02
> --------------------------------------------------------------
> ----------
> 


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba