Web lists-archives.com

Re: [Samba] explorer.exe: no mapping between names and security ids was done




Howdy Rowland,

On 03/08/17 10:51, Rowland Penny via samba wrote:
On Thu, 3 Aug 2017 09:59:44 +0100
Bernie Elbourn via samba <samba@xxxxxxxxxxxxxxx> wrote:

... I just want to put this somewhere easily searchable based on the
users error message.

Upgrading a domain controller to Debian 8  (samba 3 to 4) resulted in
the message "no mapping between names and security ids was done" at
times. The message appears on the windows 7 domain pcs when running
explorer.exe. Also other basic things did not work: internet
explorer, or mapping between file types and extensions.  But only at
times.

The problem is apparent when running set in a command on the affected
windows pc. Look for the USERDOMAIN variable somewhere at the bottom
of the list. It is not set to the real domain name. In my case it was
the name of the server before it became a domain controller. I
suspect the system was hanging together due to netbios names - eek.
Mostly and for years running Debian 7, and samba 3 this was
accidentally reliable.

A quick fix is possible on the samba domain controller:

Yes, but is this an NT4-style PDC or an AD DC ?

It is probably a PDC, if so, can I suggest that as you have upgraded the
OS, it might be a good idea to think about moving to Active Directory.

Rowland

Your guess is right. It is a smb.conf security = user flavour domain ... with all the inherent historical configuration ouchies.

Ad is indeed possible but so far not needed.

Bernie



--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba