Web lists-archives.com

Re: [Samba] [SOLVED] Can't join Win10 to Samba 3.6,23




On 07/28/17 08:50, Marc Muehlfeld via samba wrote:
Am 28.07.2017 um 09:36 schrieb L.P.H. van Belle via samba:
Maybe is good to add the slow network fix also on the wiki page (above)

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System]
"SlowLinkDetectEnabled"=dword:00000000
"WaitForNetwork"=dword:00000000

Samba 4 AD DC setup's are also adviced to to set this through GPO.
I read this the first time. In the past I only set this when I had
problems with roaming profiles over WAN connections.

I think this is not something we should recommend to set in general. I
mean it's not the default on Windows and seem only to be necessary in
some cases. If this is required for Samba, we may have a bug.


Does anyone run an NT4 domain using a recent Samba version (4.5 or
later) on the PDC and can confirm that without these settings Win10
clients can't log on?


Regards,
Marc


As a slight tangent- if you have upgraded from Samba 3.x to 4.x, check your min and max protocol settings. Samba 4 adds support for SMB3 but you may need to set max protocol to SMB2 for Win 10 support. Win 7 doesn't use SMB3 so won't try to use it even if enabled on the server. Window 10 and Samba 4 don't seem to negotiate SMB3 properly - at least with versions I tested. You don't want to upgrade from Samba 3 to 4 and inadvertently add new variables.




--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba