Web lists-archives.com

[Samba] Debian Jessie (4.5.8/4.5.12/4.6.6) and Stretch (4.6.5/4.6.6) samba packages available




Hai, 
 
I've updated samba in my apt repo. ...  reading this post back, its always longer then expected.. :-/ 
but better to much info then to little. ;-)
 
All version include the lastest CVE update. ( Jessie/Stretch ) 
 
Quick Install Info here : http://apt.van-belle.nl/ ;
 
Generals info : http://downloads.van-belle.nl/samba4/
Read the : README.txt and Upgrade-info.txt 
 
Buildlogs and changelogs of all version : http://downloads.van-belle.nl/samba4/Buildlogs/
 
The following is done.
For Jessie. 
jessie-backports   got the latest rebuild from debian stretch ( 4.5.8 ), a backport without any changes. 
jessie                  got the latest samba.org 4.5.12 version. 
unstable              got the latest samba.org 4.6.6 version.  
 
For Stretch
stretch-backports   got the latest rebuild from debian buster/testing ( 4.6.5 ), a backport without any changes. 
stretch                 got the latest samba.org 4.6.6
stretch-unstable    Unavailable for now, this wil be the next line ( 4.7 ) 
 
On the question, will i build a 4.5.12 package for stretch also?
Well, i can, but...  i personaly preffer you switch to 4.6. 
This has also todo that its lots of work to maintain this all. 
When looking at : https://wiki.samba.org/index.php/Samba_Release_Planning ;
I try to follow the current stable and maintenance from samba.org and what matches best with the debian releases.
 


Upgrading from Jessie to stretch with my packages?  
- If you use jessie-backport only from my apt, upgrade and done, you wil match the current stretch version. 
 
- If you use jessie+jessie-backports from my apt, change my apt to only stretch-backports, upgrade debian.
! Your now upgrading from 4.5.12 to 4.6.5.  
! you must adjust/check you smb.conf. If upgraded fails, your smb.conf config is incorrect. 
read : https://www.samba.org/samba/history/samba-4.6.0.html ;, adjust the smb.conf.
after the adjustment run : dpkg-reconfigure -a 
and upgrade continues.
 
- if you use jessie from my apt and your on 4.6.6.,  
change the apt to stretch-backports and stretch from my apt.
and upgrade debian, this will match the 4.6.6 version again and your done. 
 
 
! tip on upgrading, always use the following order :
apt-get upgrade  ( make sure you have the latest packages of jessie )
change your apt repo settings to stretch.  ( sources.list and everyting in sources.list.d ) 
run : 
apt-get dist-upgrade -d   ( This downloads all needed package for you upgrade )  
apt-get dist-upgrade   ( now your ready for the upgrade, so get coffee and wait )
 

 
! NOTICE 1 
Due to changes in the debian package, which i use as base, your apt-get upgrade ( for 4.5.x/4.6.x to 4.6.6 packages ) need apt-get dist-upgrade.
This is due to new setttings in these packages. ( see below ) 
 
! NOTICE 2
from Debian change log :  Release 2:4.6.5+dfsg-5 :   Remove the samba service  : debian/NEWS
The samba service has been removed. Use the individual services instead:  
 * nmbd
 * smbd
 * samba-ad-dc

 
 
Snap of the debian changelogs, some are not fully release yet, 
but are part of the change logs from debian which i used as base for the 4.6.6 packages. 
And these are included in my builds. 
 
my addition to the vanilla debian packages.: 
  * Drop CVE patch, which is included in this version. (4.6.6 builds) 
  * Added debian/patches: S12761-s3-printing-Change-to-GUID-dir-if-we-deal-with-COPY

(S12761, samba bug 12761, Uploading 32-bit drivers to a Samba 4.6 print server fail ) 
The modified patch used in the stretch 4.6.6 build.  These packages have a working upload and delete for 32bit drivers. 
see:  http://downloads.van-belle.nl/samba4/Patches/ ; 
The patch starting with debian-S12761 is applied in my stretch 4.6.6 package.
Big thank you for Achim Gottinger, who made this happen. 
 
 
+samba (2:4.6.5+dfsg-6) unstable; urgency=medium
+
+ * libcephfs-dev is only available on linux
+ * Fix libpam-winbind.prerm to be multiarch-safe (Closes: #647430)
+ * Add missing logrotate for /var/log/samba/log.samba (Closes: #803924)
+ * Use smbcontrol in logrotate when available (Closes: #804705)
+ * From upstream: Fix outdated DNS Root servers (Closes: #865406)
+ * Drop xsltproc_dont_build_smb.conf.5.patch, as #750593 is marked fixed
+ (Closes: #776223)
 
samba (2:4.6.5+dfsg-5) unstable; urgency=medium +
+ * Remove bug_598313_upstream_7499-nss_wins-dont-clobber-daemons-logs.patch,
+ unused
+ * Remove samba-ad-dc.templates
+ * Remove upstart files on upgrade (Closes: #867688)
+ * glusterfs-common is only available on linux
+ * Remove the samba service
+ * Ensure /var/log/samba permissions are set (Closes: #711138)
 
samba (2:4.6.5+dfsg-4) was the debian CVE release. 
 
 
My output on a Jessie server:  apt-cache policy samba
samba:
  Installed: 2:4.6.6+dfsg-1nmu1
  Candidate: 2:4.6.6+dfsg-1nmu1
  Version table:
 *** 2:4.6.6+dfsg-1nmu1 0
        500 http://apt.van-belle.nl/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
     2:4.5.12+dfsg-1nmu1 0
        500 http://apt.van-belle.nl/debian/ jessie/main amd64 Packages
     2:4.5.8+dfsg-2+deb9u1~bpo8+1 0
        500 http://apt.van-belle.nl/debian/ jessie-backports/main amd64 Packages
     2:4.2.14+dfsg-0+deb8u7+b1 0
        500 http://security.debian.org/ jessie/updates/main amd64 Packages
     2:4.2.14+dfsg-0+deb8u5 0
        500 http://ftp.nl.debian.org/debian/ jessie/main amd64 Packages

 
My output on a Stretch server:  apt-cache policy samba
samba:
  Installed: 2:4.6.6+dfsg-1nmu1~deb9
  Candidate: 2:4.6.6+dfsg-1nmu1~deb9
  Version table:
 *** 2:4.6.6+dfsg-1nmu1~deb9 500
        500 http://apt.van-belle.nl/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
     2:4.6.5+dfsg-5~bpo9+1 500
        500 http://apt.van-belle.nl/debian stretch-backports/main amd64 Packages
     2:4.5.8+dfsg-2+deb9u1+b1 500
        500 http://security.debian.org stretch/updates/main amd64 Packages
     2:4.5.8+dfsg-2 500
        500 http://ftp.nl.debian.org/debian stretch/main amd64 Packages

If you run 4.6.x and update to 4.6.6, you need to run : apt-get dist-upgrade 
Example :  
apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  glusterfs-common libdevmapper-event1.02.1 libibverbs1 liblvm2app2.2 librdmacm1
The following packages will be upgraded:
  libnss-winbind libpam-winbind libwbclient0 python-samba samba samba-common samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules winbind
11 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.


 
 
Have fun with these. 
 
 
Greetz, 


 
Louis
 

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba