Web lists-archives.com

Re: [Samba] LDAP authentication not working




On Mon, 2017-07-10 at 23:18 -0700, Bartra1212 via samba wrote:
> I just tried this ldapsearch command:
> ldapsearch -H ldap://localhost -x
> # extended LDIF
> #
> # LDAPv3
> # base <dc=example,dc=com> (default) with scope subtree
> # filter: (objectclass=*)
> # requesting: ALL
> #
> 
> # search result
> search: 2
> result: 1 Operations error
> text: 00002020: Operation unavailable without authentication

Unlike common configurations with OpenLDAP, Samba and Windows AD
require authentication before you can access the domain tree.

> # numResponses: 1
> 
> 
> seems like a authentication problem.As you can see I added"ldap server
> require strong auth = no" to my smb.conf but it don't work for my problem
> :/..........Has anyone a tip for me?

The setting you set is about allowing simple binds unprotected by SSL,
allowing sessions to be trivially taken over by anyone on the network. 
  (that is why the default is yes).   It isn't about allowing anonymous
access, which is enabled with the same in-directory setting as windows
AD, but which really shouldn't be set. 

Andrew Bartlett

-- 
Andrew Bartlett                       http://samba.org/~abartlet/
Authentication Developer, Samba Team  http://samba.org
Samba Developer, Catalyst IT          http://catalyst.net.nz/services/samba


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba