Web lists-archives.com

[Samba] [4.2.14-Debian] Smbd not listening on 192.168.0.x on cold start




Hello,

I noticed a problem when cold-starting a Debian host: smbd doesn't listen on
192.168.0.x. I need to restart it through the Initd script:

Cold start:
========
root@debian:~# netstat -tunlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
PID/Program name
tcp        0      0 127.0.0.1:445           0.0.0.0:*               LISTEN     
720/smbd
tcp        0      0 127.0.0.1:139           0.0.0.0:*               LISTEN     
720/smbd
tcp6       0      0 ::1:445                 :::*                    LISTEN     
720/smbd
tcp6       0      0 ::1:139                 :::*                    LISTEN     
720/smbd
udp        0      0 192.168.0.255:137       0.0.0.0:*                          
710/nmbd
udp        0      0 192.168.0.7:137         0.0.0.0:*                          
710/nmbd
udp        0      0 0.0.0.0:137             0.0.0.0:*                          
710/nmbd
udp        0      0 192.168.0.255:138       0.0.0.0:*                          
710/nmbd
udp        0      0 192.168.0.7:138         0.0.0.0:*                          
710/nmbd
udp        0      0 0.0.0.0:138             0.0.0.0:*                          
710/nmbd
========

Restart through Init script:
========
root@debian:~# /etc/init.d/samba restart
[ ok ] Restarting nmbd (via systemctl): nmbd.service.
[ ok ] Restarting smbd (via systemctl): smbd.service.
[ ok ] Restarting samba-ad-dc (via systemctl): samba-ad-dc.service.
========

Hot start
========
root@debian:~# netstat -tunlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
PID/Program name
tcp        0      0 192.168.0.7:445         0.0.0.0:*               LISTEN     
900/smbd
tcp        0      0 127.0.0.1:445           0.0.0.0:*               LISTEN     
900/smbd
tcp        0      0 192.168.0.7:139         0.0.0.0:*               LISTEN     
900/smbd
tcp        0      0 127.0.0.1:139           0.0.0.0:*               LISTEN     
900/smbd
tcp6       0      0 ::1:445                 :::*                    LISTEN     
900/smbd
tcp6       0      0 ::1:139                 :::*                    LISTEN     
900/smbd
udp        0      0 192.168.0.255:137       0.0.0.0:*                          
857/nmbd
udp        0      0 192.168.0.7:137         0.0.0.0:*                          
857/nmbd
udp        0      0 0.0.0.0:137             0.0.0.0:*                          
857/nmbd
udp        0      0 192.168.0.255:138       0.0.0.0:*                          
857/nmbd
udp        0      0 192.168.0.7:138         0.0.0.0:*                          
857/nmbd
udp        0      0 0.0.0.0:138             0.0.0.0:*                          
857/nmbd
========

Any idea why?

Thank you.



--
View this message in context: http://samba.2283325.n4.nabble.com/4-2-14-Debian-Smbd-not-listening-on-192-168-0-x-on-cold-start-tp4720131.html
Sent from the Samba - General mailing list archive at Nabble.com.

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba