Web lists-archives.com

Re: [Samba] define defaults for mount -t cifs




Hi Louis,

On 05/19/2017 12:10 PM, L.P.H. van Belle via samba wrote:
Hai MJ,

Have you tried:

apt-get install cifs-utils if its not installed.
man mount.cifs  ( if cifs-utils isnt installed no mount.cifs on debian.)

And test with :
mount.cifs //server/share /mnt/point -o vers=2.1

Greetz,

Louis

But that has nothing to do with my question, the mounts work, I just want to make mount.cifs use vers=2.1 as a minimum.

Short background WHY::
I am using a piece of software called pydio that uses mount.cifs to mount samba shares. Adjusting the way pydio executes mount.cifs does not work, and all mounts end up with the default vers=1.0

Sure: easiest would be to edit pydio config, but since that turns out to be difficut, I thought I'd try to change the default vers of mount.cifs to vers=2.1

MJ

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba