Web lists-archives.com

Re: [Samba] Samba printserver works for Win10 Pro but not Win10 Home edition




Hi Kjetil,

Am 17.05.2017 um 08:09 schrieb Kjetil Fleten via samba:
I have set up a Samba printserver at a school. The server is a standalone server, connected to no domain. I have installed printers with Cups, and uploaded Windows printerdrivers to the shared driver folder. I can add the shared printers in a Windows 10 Pro client, without any hassle. When I try the same in any Win 10 Home edition, I get Windows error messages like "error 0x000006d1" and likewise. This could possibly be fixed on each individual PC with a registry fix like this: http://blog.realcomputerguy.com/2013/06/fix-error-0x000006d1-using-level-3.html. The problem is, that we can not make such a demand to pupils on a school that brings their own device. I believe there must be a permission problem somewhere in my smb.conf, even if guests are allowed, permissions are set to 777 in all relevant folders etc.
Anyone that have experienced this ?


This bug is open since 8 years: :-/
https://bugzilla.samba.org/show_bug.cgi?id=6559


What Samba version do you use? 4.6 contains several printer enhancements that maybe fix the problem. If you still run <4.6, please update to 4.6.3, retry, and update the bug report:
* If it works, add this info to the bug report.
* If it fails:
  - upload a new level 10 debug log file
  - add your use case and latest information to the bug

If you run 4.6 and require uploading 32-bit drivers, additionally apply the patch from:
https://bugzilla.samba.org/show_bug.cgi?id=12761
This will be fixed in 4.6.4.



Regards,
Marc

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba