Web lists-archives.com

Re: [Samba] unable to run samba 4.6.2 bits compiled from source






Am 24.04.2017 um 15:06 schrieb Amritanshu via samba
I got hold of samba 4.6.2 Tar from the official repo, configured, compiled,
and installed the bits. Unfortunately I am running into the following error:

~/work/samba-4.6.2$ smbstatus
smbstatus: /usr/lib/x86_64-linux-gnu/libndr.so.0: version `NDR_0.0.6' not
found (required by /usr/lib/samba/libsmbd-base-samba4.so)
smbstatus: /usr/lib/x86_64-linux-gnu/libndr.so.0: version `NDR_0.0.6' not
found (required by /usr/lib/samba/libndr-samba-samba4.so)
the commands I have used to build the bits are:

sudo ./configure                            \
     --prefix=/usr                      \
     --sysconfdir=/etc                  \
     --localstatedir=/var               \
     --with-piddir=/run/samba           \
     --with-pammodulesdir=/lib/security \
     --without-ad-dc                      \
     --without-systemd                  \
     --enable-debug \
     --enable-fhs                           \
     --enable-selftest
sudo make &>build.log
sudo make &>install.log

a lot of mistakes

* don't run configure and make with root permissions
* don't use --prefix=/usr and spit your build without
  proper packaging and so dependency solving in the
  middle of your package based os install
* the second "sudo make" (the only one with sudo) should
  have been "sudo make install"

--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba