Web lists-archives.com

Re: [Samba] Is FSCTL_VALIDATE_NEGOTIATE_INFO mandatory in samba-4.4 & onwards




On Thu, Apr 20, 2017 at 04:31:30PM +0530, amit kumar via samba-technical wrote:
> Hello,
> 
> I was reading about secure Dialect negotiation to prevent man-in-middle
> to downgrade dialects & capabilities.
> _https://blogs.msdn.microsoft.com/openspecification/2012/06/28/smb3-secure-dialect-negotiation/_
> 
> I wanted to ask, is there any option to disable SMB2 to do dialect
> renegotiation as present in Windows8 clients, as they can control using
> RequireSecureNegotiate.

No, right now this is mandatory in the SMB2+ client code.

Why do you want to turn this off ?

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba