Web lists-archives.com

[Samba] Windows client domain member getting incorrect value for LOGONSERVER




Greetings,

We migrated to new hardware our very first Samba PDC we built back in 2004 this past weekend. Now that Samba PDC is on its third set of hardware since being built. Bravo Samba team for all the hard work you do so our lives may be vastly simplified!

The last server started out being loaded with Ubuntu 9.04, and we had upgraded it all the way to Ubuntu 16.04. Now this third set of hardware starts out at Ubuntu 16.04, and we shall see how many LTS upgrades it makes it through! :-)

Question about a hard spot we encountered... one Windows machine joined to the domain is insisting on setting its LOGONSERVER to its own hostname rather than the PDC it logs into. See example:

C:\>set | grep -i logonserver
LOGONSERVER=\\LDSWNT01

C:\>NETDOM QUERY /domain:lds-smb PDC
Primary domain controller for the domain:
LDSLNX01
The command completed successfully.


The usual domain userid still works properly on the machine after the PDC migration. Thus I am concluding the Windows machine still thinks it is a member of the Samba PDC.

Other Windows machines are correctly showing that LOGONSERVER=\\LDSLNX01

I believe the default value of that variable in Windows is to echo COMPUTERNAME as LOGONSERVER if not joined to a domain. So it is as if the machine now is reduced to being 1/2 joined to the Samba domain.

Please could you kindly suggest things we could validate to see why this one Windows computer is causing trouble?

I am thankful,

--
Michael Lueck
Lueck Data Systems
http://www.lueckdatasystems.com/


--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba