Web lists-archives.com

Re: [Samba] LDAP logins failing after installing Samba 4.4.5




On Tue, 2017-03-07 at 09:05 +0000, Rowland Penny via samba wrote:
> On Tue, 7 Mar 2017 01:50:31 +0100
> Bart Coninckx via samba <samba@xxxxxxxxxxxxxxx> wrote:
> 
> > Hi all,
> > 
> >  
> > I had an LDAP application (mailserver) running on Samba 4.1.3 which
> > wrked flawlessly. Also using an LDAP browser with a simple bind
> > worked OK.
> > 
> > I than replaced the Samba installation with version 4.5 and the
> > LDAP
> > functionality broke. I first thought it had to do with a non-SSL or
> > non -TLS and though I now get an error message when doing a simple
> > bind without encryption, activating encryption does not work
> > either.
> > 
> >  
> > Is there a way to configure how Samba expects LDAP binds to happen?
> 
> AD does not allow simple binds, It might help if you told us just
> what
> mailserver you are using.

To be clear, AD does allow simple binds.  We restrict them in Samba per
the "ldap server require strong auth" parameter. 

Thanks,

Andrew Bartlett

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba