Web lists-archives.com

Re: [Samba] Missing security tab samba 4.1.13




>> I just realized that I omitted an important piece of information and
>> that is that I am using a separate EXT4 volume for my shares. I just
>> did a test and it seems that shares on the same volume as sysvol and
>> netlogon funtion as expected but shares on the second volume have the
>> issue. 
>> 
>> I just mounted that second volume with explicit acl and user_xattr
>> options in fstab, but this makes no difference.

>It wouldn't, amongst the defaults for EXT4 are 'acl' & 'user_xattr' and
>it shouldn't matter if the shares are on a different partition.
>
>Rowland

I agree. Yet it does. I just did the tests on https://wiki.samba.org/index.php/File_System_Support , which went successfull, so my EXT4 volume has the necessary attributes activated. For Samba there must exist a difference in between my root volume and my data volume.

 
This is my smb.conf currently:

 
# Global parameters
[global]
netbios name = LX01
realm = DOMAIN.COM
workgroup = DOMAIN
dns forwarder = 8.8.8.8
server role = active directory domain controller
idmap_ldb:use rfc2307 = yes
 [netlogon]
path = /usr/local/samba/var/locks/sysvol/domain.com/scripts
read only = No
 [sysvol]
path = /usr/local/samba/var/locks/sysvol
read only = No
 [Data]
        path = /data/smb/data
        read only = No
 [test]
path = /test
read only = No 
 
-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba