Web lists-archives.com

Re: [Samba] Missing security tab samba 4.1.13




On Sat, 4 Mar 2017 22:09:16 +0100
Bart Coninckx via samba <samba@xxxxxxxxxxxxxxx> wrote:

> Hi all,
> 
>  
> I followed the installation instructions
> on https://imanudin.net/2014/11/16/how-to-install-samba4-active-directory-on-centos-7-part-1/#comment-16611
> to install Samba 4.1.13. One difference is that I used the Internal
> DNS server as opposed to the external one. 

I suppose you totally missed the fact that the 4.1.x series went EOL
quite some time ago, in fact 4.6.0 should be out this month.

Why follow that particular howto ?

> 
>  
> I was able to add a Windows 7 Pro workstation to the domain and I see
> the shares I added in smb.conf (with only the path and the read only
> setting to "no"), but on those shares I miss the Security tab. I
> added the correct privilege to the administrators group.The default
> shares like netlogon and sysvol do show the Security tab. 
> 
> I did see a difference when I do a getfacl for those folders as
> opposed to the ones I created. For the latter I do not get any ACL
> configuration.
> 
>  
> Am I supposed to do a manual setfacl for my own shares?

Yes

> 
> One other thing is that the administration of the shares behaves
> unstable when I have IPv6 enabled, so that is disabled now.

Could be down to not having the reverse zone set up.

> 
>  
> I have been browsing the web for hours, but it doesn not seem to be a
> typical problem.

Did you think to go to the source ????

https://wiki.samba.org/index.php/Main_Page

Specifically this page:

https://wiki.samba.org/index.php/Setting_up_a_Share_Using_Windows_ACLs

Rowland


-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba