Web lists-archives.com

Re: [Samba] wbinfo -i returns the same id for all users, authentication doesn't seem to go through winbind at all




Emmanuel Florac via samba wrote:
Unknown parameter encountered: "winbind enumerate users"
Ignoring unknown parameter "winbind enumerate users"
Unknown parameter encountered: "winbind enumerate groups"
Ignoring unknown parameter "winbind enumerate groups"

It may be irrelevant, but I have:

 winbind enum groups = Yes
 winbind enum users = Yes

in mine.  The manpage makes no reference to 'enumerate' as a valid
option.


---------------------------
Rowland Penny via samba wrote:
If you want to show all users and groups, you will need to add these
lines to smb.conf:

   winbind enumerate users = yes
   winbind enumerate groups = yes
Only do this for testing.
----

Eh?  The man page says that turning off enumeration may cause
programs to behave 'oddly' [i.e randomly or to exhibit undocumented
behavior].  That doesn't sound like a "good thing".  Perhaps
you are thinking about the advice on 'winbind expand groups'
where it cautions about high values possibly resulting in server
slowdown?

Remember what I said about using lists from my server
to find out what USERs & GROUPs are available -- turning that off
would not be good for me.

Is there something that has changed to make the older manpage's
advice no longer valid?

Tnx!
-l




--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba