Web lists-archives.com

Re: [Samba] Minimum python 2.7 (not on RHEL6) for Samba 4.7 AD DC?




Il giorno sab, 18/02/2017 alle 07.53 +1300, Andrew Bartlett via samba
ha scritto:
>  - If so, would an upgrade to RHEL7 be likely before you deploy Samba
> 4.7 in late 2017?

RHEL/Centos 7.3 (last today update) already has python 2.7.x,
RHEL/Centos 6 not.
 
> [lesca@server-dati ~]$ cat /etc/redhat-release
> CentOS Linux release 7.3.1611 (Core) 
> [lesca@server-dati ~]$ python --version
> Python 2.7.5
> [lesca@server-dati ~]$ 

Centos [6,7]* however does not have into current samba 4.x version 
fully support to AD DC (without rebuild the source with some few
changes):

> [lesca@dodo ~]$ rpm -ql samba-dc
> /usr/share/doc/samba-dc
> /usr/share/doc/samba-dc/README.dc
> [lesca@dodo ~]$ cat /usr/share/doc/samba-dc/README.dc
> MIT Kerberos 5 Support
> =======================
> ...The Samba build in Fedora is using MIT Kerberos
> implementation in order to allow system-wide interoperability between
> both desktop and server applications running on the same machine.
> 
> At the moment the Samba Active Directory Domain Controller
> implementation is not available with MIT Kereberos. FreeIPA and Samba
> Team members are currently working on Samba MIT Kerberos support as
> this is a requirement for a GNU/Linux distribution integration of
> Samba AD DC features.
> 
> We have just finished migrating the file server and all client
> utilities to MIT Kerberos.  The result of this work is available in
> samba-* packages in Fedora. We'll provide Samba AD DC functionality
> as soon as its support of MIT Kerberos KDC will be ready.

How do you deploy samba AD DC on Centos?

Manually rebuild it or ...

You know that Samba 4.7 will have support to AD-DC with MIT Kerberos?

Thank for reply

-- 
Dario Lesca
(inviato dal mio Linux Fedora 25 Workstation)

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba