Web lists-archives.com

Re: [Samba] Conversion error Illegal multibyte sequence in smbstatus




Because of Plain text mode, my output example is split across several
lines and hence is totally meaningless.
If you want to see the example, follow this link :
http://download.caoba.fr/r3tb7hxb2pl5/
I marked in red the places where the bug appears.

-------------------------
Santiago DIEZ
Quark Systems & CAOBA
23 rue du Buisson Saint-Louis, 75010 Paris
-------------------------


On Thu, Feb 2, 2017 at 3:10 PM, Santiago DIEZ <santiago.diez@xxxxxxxx> wrote:
> Hi,
>
> My output of smbstatus is bugged somehow in the Locked files section.
> For every line with a non ascii character, the whole string from the
> character to the end (included) is removed. Hence the line is attached
> to the next one.
>
> Here is a simplified example
>
> Locked files:
> Pid   ... SharePath   Name   Time
> ---------------------------------
> 8910  ... /path
> to/a/file/with/a/non/ascii/character/imediately/followed/by/next/line8595
> ... /path   to/a/file/with/only/ascii/characters   Thu Feb  2 14:17:16
> 2017
> 8910  ... /path   to/a/file/with/only/ascii/characters   Thu Feb  2
> 14:17:16 2017
> 8910  ... /path
> to/a/file/with/a/non/ascii/character/imediately/followed/by/next/line8910
> ... /path   to/a/file/with/a/non/ascii/character/imediately/followed/by/next/line13570
> ... /path   to/a/file/with/only/ascii/characters   Thu Feb  2 14:17:16
> 2017
> 13947 ... /path   to/a/file/with/only/ascii/characters   Thu Feb  2
> 14:17:16 2017
>
> If i use debug=3, for every bugged line, I see a message :
> convert_string_internal: Conversion error: Illegal multibyte sequence()
>
> I'm using samba-3.6.25.
>
> the output of "locale" is :
> LANG=en_US.UTF-8
> LANGUAGE=
> LC_CTYPE="en_US.UTF-8"
> LC_NUMERIC="en_US.UTF-8"
> LC_TIME="en_US.UTF-8"
> LC_COLLATE="en_US.UTF-8"
> LC_MONETARY="en_US.UTF-8"
> LC_MESSAGES="en_US.UTF-8"
> LC_PAPER="en_US.UTF-8"
> LC_NAME="en_US.UTF-8"
> LC_ADDRESS="en_US.UTF-8"
> LC_TELEPHONE="en_US.UTF-8"
> LC_MEASUREMENT="en_US.UTF-8"
> LC_IDENTIFICATION="en_US.UTF-8"
> LC_ALL=
>
> The output of "testparm -s -v | grep -i charset" is
> dos charset = CP850
> unix charset = UTF-8
> display charset = LOCALE
>
> Do you know how to fix the display of smbstatus ? I don't know what
> else to check, I have another server with the exact same parameters I
> just gave and it displays smbstatus correctly.
>
> Thanks for your help.
>
> -------------------------
> Santiago DIEZ
> Quark Systems & CAOBA
> 23 rue du Buisson Saint-Louis, 75010 Paris
> -------------------------

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba