Web lists-archives.com

[Samba] Stalled Replication & "DsGetNCChanges 2nd replication"




I am attempting to add a Windows 2008R2 DC to my S4 domain... and it always stalls out attempting to replicate CN=Configuration object X of Y. So I have been digging, digging, digging, and I found this in the log file of the DC the 2008R2 box is attempting to replicate from -

Feb 1 16:52:42 larkin28 samba[18650]: ../source4/rpc_server/drsuapi/getncchanges.c:1961: DsGetNCChanges 2nd replication on DN CN=Configuration,DC=micore,DC=us older highwatermark (last_dn CN=414,CN=DisplaySpecifiers,CN=Configuration,DC=micore,DC=us) Feb 1 16:52:44 larkin28 samba[18650]: [2017/02/01 16:52:44.553389, 0] ../source4/rpc_server/drsuapi/getncchanges.c:1961(dcesrv_drsuapi_DsGetNCChanges) Feb 1 16:52:44 larkin28 samba[18650]: ../source4/rpc_server/drsuapi/getncchanges.c:1961: DsGetNCChanges 2nd replication on DN CN=Configuration,DC=micore,DC=us older highwatermark (last_dn CN=414,CN=DisplaySpecifiers,CN=Configuration,DC=micore,DC=us) Feb 1 16:53:33 larkin28 samba[18650]: [2017/02/01 16:53:33.282166, 0] ../source4/rpc_server/drsuapi/getncchanges.c:1961(dcesrv_drsuapi_DsGetNCChanges) Feb 1 16:53:33 larkin28 samba[18650]: ../source4/rpc_server/drsuapi/getncchanges.c:1961: DsGetNCChanges 2nd replication on DN CN=Configuration,DC=micore,DC=us older highwatermark (last_dn CN=414,CN=DisplaySpecifiers,CN=Configuration,DC=micore,DC=us) Feb 1 16:53:47 larkin28 samba[18650]: [2017/02/01 16:53:47.394951, 0] ../source4/rpc_server/drsuapi/getncchanges.c:1961(dcesrv_drsuapi_DsGetNCChanges) Feb 1 16:53:47 larkin28 samba[18650]: ../source4/rpc_server/drsuapi/getncchanges.c:1961: DsGetNCChanges 2nd replication on DN CN=Configuration,DC=micore,DC=us older highwatermark (last_dn CN=414,CN=DisplaySpecifiers,CN=Configuration,DC=micore,DC=us) Feb 1 16:54:09 larkin28 samba[18650]: [2017/02/01 16:54:09.015323, 0] ../source4/rpc_server/drsuapi/getncchanges.c:1961(dcesrv_drsuapi_DsGetNCChanges)

This goes on and on and on with this object.

To anyone who knows more than me does this look like a possible source of the problem?

And what is "CN=414,CN=DisplaySpecifiers,..."? It seems to have something to do with Exchange.

[root@larkin28 samba]# ldbsearch --extended-dn --reveal --cross-ncs -H /var/lib/samba/private/sam.ldb --show-recycled --show-deleted -s sub CN=414 dn: <GUID=8a714d09-a31c-4a1d-9e6b-4522fbd55da9>;CN=414,CN=DisplaySpecifiers,CN=Configuration,DC=micore,DC=us
objectClass: top
objectClass: container
cn: 414
instanceType: 4
whenCreated: 20121215005505.0Z
whenChanged: 20121215005505.0Z
uSNCreated: 1663
showInAdvancedViewOnly: TRUE
name: 414
objectGUID: 8a714d09-a31c-4a1d-9e6b-4522fbd55da9
objectCategory: <GUID=5796590e-095c-4a74-8f75-479bef316615>;CN=Container,CN=Sc
 hema,CN=Configuration,DC=micore,DC=us
uSNChanged: 286105
distinguishedName: <GUID=8a714d09-a31c-4a1d-9e6b-4522fbd55da9>;CN=414,CN=Displ
 aySpecifiers,CN=Configuration,DC=micore,DC=us




--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba