Web lists-archives.com

Re: [Samba] Samba-4.3 AD-DC Win7pro clients not time syncing




On Mon, 30 Jan 2017 12:16:30 -0500 James B. Byrne wrote:

> I set the client's w32tm configuration this way:
>
> w32tm /config /update /manualpeerlist:"time.nrc.ca time.chu.nrc.ca"
> /syncfromflags:ALL
>
> And when I check the status with
>
> w32tm /query /status
>
> then I see this:
>
> Leap Indicator: 0(no warning)
> Stratum: 3 (secondary reference - synced by (S)NTP)
> Precision: -6 (15.62ms per tick)
> Root Delay: 0.0313721s
> Root Dispersion: 0.2973346s
> ReferenceId: 0x84F60BE3 (source IP: 132.246.11.227)
> Last Successful Sync Time: 2017-01-30 11:46:22
> Source: time.nrc.ca
> Poll Interval: 11 (2048s)
>
> And if I do this:
>
> w32tm /resync /rediscover
> Sending resync command to local computer
> The computer did not resync because no time data was available.
>
> I am afraid that I am mystified by this.  Have I misconfigured
> something on the Samba server to account for this behaviour?  I have
> not previously run into this problem before but I have seen from my
> researches that many people have had this issue with MicroSoft servers
> so it does not appear a Samba specific thing but I cannot be sure.
>
> In any case, How does one fix this?

This is what worked for me:

$ w32tm /config /manualpeerlist:mail,0x8 /syncfromflags:MANUAL 
$ w32tm /config /update

where 'mail' is my Samba4 AD/DC.

"Depending on the type of the Windows PC ..., NTP servers may not respond to the type of
queries sent by w32time.  w32time sends namely symmetric active instead of client mode packets
to a NTP server. ... The flag "0x8" forces w32time not to send "symmetric active" packets but
normal "client" requests which the NTP server replies to as usual."

ref. https://www.meinbergglobal.com/english/info/ntp-w32time.htm

--Mark

-- 
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba